2

In System > Cache Management all types are disabled. Each morning when I log into Magento (sometimes the previous evening also) all cache types will have been re-enabled.

This is very strange. I have crawled through each installed extension and disabled yet each day Magento cache is re-enabling itself.

Is there some buried cache Magento feature that I do not know about?

  • What do you mean by 'cache is re-enabled'? Keep in mind that not only Magento writes the cache in var/cache. ZF also does it. And ZF does not care if the cache is disabled because...well..."HE"'s ZF. – Marius Sep 19 '14 at 13:59
  • Sorry, I mean that in System > Cache Management all types are disabled. I'll return to work in the morning and all blocks will have been re-enabled. – TylersSN Sep 19 '14 at 14:04
  • @iUseMagentoNow I hope not to see another thread with title 'Magento cache keeps disabling itself every evening'. Just kidding ;) – Kalpesh Sep 19 '14 at 17:53
  • DId you ever find out what this was? – alexjamesbrown Feb 27 '16 at 9:33
  • 1
    This was a while back, but if I remember correctly (* looks around to make sure nobody is listening *) this was caused by a faulty read replica database. – TylersSN Mar 17 '17 at 20:34
2

I would say to check for all the crons which could re-enable all the caches in late-evening/night.

  1. Check linux cron

    crontab -l

  2. Check magento's cron

    select job_type, scheduled_at, executed_at from cron_schedule

  3. Make sure someone is not doing this manually unintentionally.
2

The fact that it happens every night without fail indeed suggests it has something to do with the cron.

When you say you "disabled each installed extension", do you mean that you deactivated each extension via its config XML, or you disabled module output via the Admin panel? If you did the latter, I'm pretty sure that would only stop it from outputting stuff on the frontend or backend, not actually stop it from running backend processes (like cron).

If you need help analyzing your Magento crons, Fabrizio Branca's Aoe_Scheduler (https://github.com/AOEpeople/Aoe_Scheduler) module is very helpful at telling you what ran when, and for how long. Additionally, you can manually run cron tasks at will, so you could try disabling the cache and running one of your third-party module's cron tasks, and seeing if the caches are still disabled. (Provided of course that there are no adverse effects from running the cron, e.g. - duplicate table rows, emailing actual customers, etc.)

1

While I cannot provide insight on why this issue is occuring I may be able to offer a couple of temporary solutions.

1) The cron script You can create a script to disable all cache types, and have it run periodically through Magento cron to make sure they stay disabled.

require_once 'app/Mage.php';
Mage::app('admin');
Mage::app()->cleanAllSessions();
Mage::app()->getCacheInstance()->flush();
Mage::app()->cleanCache();

$cachetypes = array(
          0 => 'config', 
          1 => 'layout',
          2 => 'block_html', 
          3 => 'translate', 
          4 => 'collections',
          5 => 'eav',
          6 => 'config_api',
          7 => 'fullpage',
          8=>'config_api2');

 $caches = Mage::app()->useCache();
 $changed = 0;

foreach ($cachetypes as $cache) {
    if (!empty($caches[$cache])) {

        $caches[$cache] = 0;
        $changed++;

    }
    Mage::app()->getCacheInstance()->cleanType($cache);
}
if ($changed > 0) {
    Mage::app()->saveUseCache($caches);
}

2) The MySQL Way You could also modify the database itself and see if that sticks, or script it to run periodically like the cron.

UPDATE `core_cache_option` SET value=0;
  • Simply updating the core_cache_option table doesn't de-activate the cache – alexjamesbrown Feb 27 '16 at 8:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.