0

I have created a VM with a clean install of Magento 2.4.4 that is working correctly. PHP 8.1, Mysql 8 and ElasticSearch. I have installed the Alpaca Theme https://github.com/SnowdogApps/magento2-alpaca-theme using the command

npx @snowdog/create-alpaca-theme

I can change to the Alpaca theme or the child theme with no errors in the back end however after enabling either of these themes, I am unable to load any of the pages on the frontend. An exception is thrown. Checking the exception log I get this error message

{"0":"Compilation from source: LESS file is empty: frontend\/Snowdog\/alpacachild\/en_AU\/css\/critical.less","1":"#1 Magento\\Framework\\Vie>

If I run the yarn dev command to start fractals, I can view all of the pages correctly.

I am unsure of where to go next with this.

Update: The error says the file critical.less is empty however when I navigate the folder structure, the folder en_AU does not exist in the alpacachild folder. The folder contents are:

-rw-rw-r-- 1 brett brett    98 Jan 29 18:57 CHANGELOG.md
drwxrwxr-x 3 brett brett  4096 Jan 29 18:57 Magento_Checkout
-rw-rw-r-- 1 brett brett 39314 Jan 29 18:57 preview.jpg
-rw-rw-r-- 1 brett brett   130 Jan 29 18:57 README.md
-rw-rw-r-- 1 brett brett   177 Jan 29 18:57 registration.php
drwxrwxr-x 6 brett brett  4096 Feb  8 21:47 Snowdog_Components
drwxrwxr-x 2 brett brett  4096 Jan 29 18:57 styles
-rw-rw-r-- 1 brett brett   289 Jan 29 18:57 theme.xml
-rw-rw-r-- 1 brett brett   298 Jan 29 18:57 vercel.json
drwxrwxr-x 3 brett brett  4096 Feb  3 21:04 web

I have created the critical.less file in the app/design/frontend/Snowdog/alpaca-child/en_AU/css folder and then redeployed the static content. Has made no difference to the web page.

I've changed the setting in the Admin backend for Use CSS Critical Path to No but this made no difference.

It does not matter whether the Alpaca theme or the child theme is used. The same error is thrown. The folder location for the critical.less file will vary based on theme selected.

I've tried copying the critical.less file to the static folder location and the generated folder location but this doesn't work either.

Exception

Theme Selection

yarn dev command

1 Answer 1

0

I found the solution to this. The issue was raised on their Github page and required changing the region in one of the config pages.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.