0

I've been painstakingly trying to update our magento installation from 2.3.5 running on php 7.4, to 2.4.4 running on php 8.1. Ive managed to solve most weird dependancy requirements to a solvable set of packages. However, I'm running into a weird 1 now. My Composer is saying the following:

 - magento/product-community-edition 2.4.4 requires magento/magento2-base 2.4.4 -> satisfiable by magento/magento2-base[2.4.4].
- magento/magento2-base[2.4.4] cannot be installed as that would require removing magento/project-community-edition[2.4.4]. They all replace trentrichardson/jquery-timepicker-addon and thus cannot coexist.
- magento/project-community-edition is present at version 2.4.4 and cannot be modified by Composer
- Root composer.json requires magento/product-community-edition 2.4.4 -> satisfiable by magento/product-community-edition[2.4.4].

My composer.json does start with this line:

{
"name": "magento/project-community-edition",
"description": "Magento 2 (Open Source)",
"type": "project",
"version": "2.4.4",
"license": [
    "OSL-3.0",
    "AFL-3.0"
],

But for some reason it seems to be conflicting with the command to upgrade

2
  • - Hello don please refer below link for update magento2.4.4 magento.stackexchange.com/questions/363648/… - Hope it's useful for you. Commented Feb 2, 2023 at 11:15
  • Hi @rahil, I have already found these steps, i had solved the dependencies as well and i ran the upgrade, however i wanna further update it. But now i cant get composer update to run cause it gives me this error, it seems composer json is unlinked from the install and sees 2 installs of magento or something.
    – don
    Commented Feb 2, 2023 at 12:32

1 Answer 1

0

It's from a comment. It helped me Just run the following command.

composer install --ignore-platform-reqs

or

composer update --ignore-platform-reqs

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.