2

I have setup Magmi several times now with succes. But the latest setup won't handle images. I have it working on a different server. I get the following error.

Image attributes processor v1.0.29 - error copying media/catalog/product/l/a/lat_i6_hx_sl01.jpg : source error,Cannot fetch http://remotedomain.com/_files/products/large/LAT_I6_HX_SL01.jpg :No URL set!

I changed the domain to mask it.

The URL does have an image. I can open it in my browser. On the other server the same product does get images imported. It seems like some sort of a permission issue. The media is recursivly set to 777.

  • 1
    make sure your are using latest magmi from git repo. github.com/dweeves/magmi-git/archive/master.zip – dweeves Sep 19 '14 at 13:57
  • Thanks for your reply. I installed magmi_full_0.7.19a from sourcefourge. Is your link any different? I am uploading it now as we speak. – Akif Sep 19 '14 at 15:18
  • I just finished testing. I don't see any changes in result. Or do I have to do something special? The version of Magmi is now v0.7.20_git. – Akif Sep 19 '14 at 15:25
  • Well if it is working on a different server with the same code, then what is different between the two servers? – kab8609 Dec 7 '14 at 1:10
0

Error you get (No URL set!) seems to be reported by curl. It doesn't seem related to directory permissions.

Magmi will use different code in image processor if curl extension is installed:
- https://github.com/dweeves/magmi-git/blob/master/magmi/plugins/extra/itemprocessors/imageprocessor/imageitattributeemprocessor.php - https://github.com/dweeves/magmi-git/blob/master/magmi/inc/remotefilegetter.php

I assume you have curl installed on latest setup, but not on working environment. Run this command on both environments. This will not resolve your issue but you'll get an idea why code behaves differently.

php -r 'var_dump(function_exists("curl_init"));';

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.