magento is sending the next error when calling a GET API. Does anyone have the solution to the error?

{ "message": "The consumer isn't authorized to access %resources.", "parameters": { "resources": "Magento_Customer::manage" },

  • You need to use token verification to access this using customer username & password that will generate a token, then you need to use that token in Bearer authentication Commented Jan 4, 2023 at 4:52
  • I'm using the bearer token authentication but anyway the error happens
    – Oier
    Commented Jan 4, 2023 at 6:59

1 Answer 1


Please check below possible solutions.

Solution 1 :

Login to Admin >> Stores >> Stores >> Settings >> Configuration >> SERVICES >> Magento Web API >> Web API Security >> Allow Anonymous Guest Access: Yes

Solution 2 :

  1. Go into System -> Integrations
  2. Check the Resource Access set to "All".
  3. check the Access Token value with the Bearer Token value.
  4. Open Postman Tool.
  5. Make a GET request to "https://[mymagentohost].com/rest/V1/xyz
  6. Set the header "Authorization" to "Bearer TOKEN"
  7. Make sure that there is no space before or after the token, only one after "Bearer"
  8. "Content-Type" header set to "application/json".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.