1

I am trying to install a new version of Magento 1.4.1.1 on a Mac with native Apache/MySQL

I am getting the following error

Database server does not support the InnoDB storage engine.

I seem to remember some solutions in the config.xml to change :

<pdo_mysql/>

to :

<pdo_mysql> 1 </pdo_mysql>

Unfortunately I don't have those lines in my config for this version.

I am just trying to install to compare tables to a newer version.

  • It only goes up to 1.7CE, but perhaps this will save you having to? – Jonathan Hussey Sep 18 '14 at 13:26
  • @JonathanHussey You rock! I forgot about that site :) – brentwpeterson Sep 18 '14 at 15:18
1

You really should use a supported version of mySQL. Most of the people at the agency I work at use MAMP http://www.mamp.info/en/ instead of native.

With that said, I never recommend modifying core files, but this solution was posted here.

Line 59 of the file app/code/core/Mage/Install/Model/Installer/Db/Mysql4.php

Replace:

public function supportEngine()
    {
        $variables  = $this->_getConnection()
            ->fetchPairs('SHOW VARIABLES');
        return (!isset($variables['have_innodb']) || $variables['have_innodb'] != 'YES') ? false : true;
    }

with this:

public function supportEngine()
    {
        $variables  = $this->_getConnection()
            ->fetchPairs('SHOW ENGINES');
        return (isset($variables['InnoDB']) && $variables['InnoDB'] != 'NO');
    }
  • I already tried that solution, the file is not in 1.4.1.1 – brentwpeterson Sep 18 '14 at 15:17
1

I was able to resolve this by commenting out lines 74-76

app/code/core/Mage/Install/Model/Installer/Db.php

if (!isset($variables['have_innodb']) || $variables['have_innodb'] != 'YES') {
           Mage::throwException(Mage::helper('install')->__('Database server does not support the InnoDB storage engine.'));
       }

Magento 1.4.1.1 installed on my local system and I was able to get the DB structure and compare tables.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.