I have checked all relevant solutions across this query but none worked for me.

I have magento 2.4.4 setup on local via xampp 8.10 On Postman, I am getting this error - Unknown connection name amqp.

In my env.php file, I tried to add the ampq configuration but that is not working fine for me. Any idea how to resolve this?

I am facing these issues parallelly-

  1. localhost/phpmyadmin is not working - Getting error mysqli::real_connect(): (HY000/1045): Access denied for user 'root'@'localhost' (using password: YES) So, to resolve the same in my.ini of mysql I added skip-grant-tables & it started working.
  2. While running setup upgrade, I am getting error - Do not have grant privileges. So, this error is coming because I have added skip-grant-tables. I have to uncomment to make this command work but that will stop phpmyadmin

Any idea how we can resolve both issues in one go? I can't run any mysql command to fix the phpMyAdmin issue because database will not work.

Please do needful


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.