1

I am having a huge problem with my Magento 2.2. and I'd like to ask for your help. Frontend works perfectly, customers can login too. I am unable to login to the Admin Panel. I can type the login details but after that I get this error message: enter image description here

I made no changes in the website before this.

Things I've done so far:

  • check for var/maintenance (there was no file btw)
  • php bin/magento indexer:reindex
  • php bin/magento cache:clean
  • php bin/magento setup:di:compile
  • php bin/magento cache:flush
  • php bin/magento setup:upgrade
  • There is no error message in debug.log, system.log
  • Created a new admin user: same result
  • checked the server usage, not even 10% (storage, processor, brandwidth etc.) was used in the past 7 days

Many thanks in advance.

1
  • Possible issues are permission or htaccess file, rename htaccess from pub and root and see what happend Dec 9, 2022 at 20:47

1 Answer 1

1

Try to run the following commands to set the correct permission:

find . -type f -exec chmod 664 {} \;
find . -type d -exec chmod 775 {} \;
find var pub/static pub/media app/etc -type f -exec chmod g+w {} \;
find var pub/static pub/media app/etc -type d -exec chmod g+ws {} \;

If the issue still persists, try to switch Magento mode to Developer to debugging:

bin/magento deploy:mode:set developer

Once you switched to Developer mode, go to the admin page and try to log in. Might be you can see the error.

When you finished debugging, switch Magento mode back to Production:

bin/magento deploy:mode:set production
1
  • I did all things above. No luck :( Same error message even in Dev mode. Thanks anyway. Dec 9, 2022 at 19:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.