I have a problem with the cache on Magento 2.3.x According to my hosting provider services, the script of Magento 2.3.x is bigger and bigger size day by day. For example, last week the size of all files and folders is 400 MB, 2 days later 500 MB, and now 2 GB, and maybe in a month, its size is approximately 32 GB.

2 Answers 2


First, you can refresh the caches via the cron job every day. The other way, we can disable the logs or fix the errors.


For this case, you should check your cache files and logs to debug what causes the file size to increase.

Steps to reproduce:

  • Disable Logs
  • Disable Cron Job and check your cron job scripting
  • Reload and check every page running the log file simultaneously.
  • Turn on Profiler to check which file loads more time
  • Check for Javascript and CSS Bundling, and try to disable it.
  • Check for max_session_size_admin

If may help you in fixes. Otherwise, upgrading to the latest version, such as 2.4.X.

Please check for the upgrade: https://devdocs.magento.com/guides/v2.4/comp-mgr/cli/cli-upgrade.html


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.