13

For some reason the template path hints are not displayed.

I went to the admin panel and turned them off and on again, then cleared the cache. But they are still not displaying.

How can I debug/solve it?

4
  • 2
    Make sure you have enabled this feature for the proper store view.
    – zitix
    May 10, 2013 at 12:59
  • 2
    Did you rewrite the Mage_Core_Block_Template and removed the feature? The code is in this class and easy to read, just check with debugger (add a die() before it) and check whether it is called. May 10, 2013 at 13:09
  • @FabianBlechschmidt how to rewrite on Mage_Core_Template? sorry i am not much familiar with hardcore php
    – Ryan Diaz
    May 10, 2013 at 14:53
  • Rewrite is a magento feature.magedev.com/magento-overriding-model-block-or-helper May 10, 2013 at 14:57

2 Answers 2

19

Try to check if your configuration backend for System > Configuration > Advanced > Developer Client Restrictions is empty or set to your correct IP address (the last case is the best pratice).

Or to follow the idea of @fabian-blechschmidt, check if you didn't have overwritten one of the methods in your Block:

  • Mage_Core_Block_Template::fetchView()
  • Mage_Core_Block_Template::renderView()
  • Mage_Core_Block_Template::_toHtml()

It may help

enter image description here

1
  • 1
    Try to check if your configuration backend for System > Configuration > Advanced > Developer Client Restrictions is empty or set to your correct IP address (the last case is the best pratice). worked for me Mar 27, 2017 at 12:22
0

use an extension instead

Easy Template Path Hints

This will save your time going into the backend each time you want to enable template path hints.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.