2

I'm using opensearch and I'm getting the following error on the category page. I'm also getting a similar error during indexing.

1 exception(s):
Exception #0 (Elasticsearch\Common\Exceptions\BadRequest400Exception): {"error":"no handler found for uri [/magento2_product_1/document/_search] and method [POST]"}

I'm using brew for opensearch, the version is 2.3.0.

1 Answer 1

1

As per system requirements from Magento official, Magento currently does not support Opensearch 2.x, it only supports Opensearch 1.2 for Magento version >=2.4.3-p2 (but in real life, you can use 1.3.4 or 1.3.6 as well).

So, I'm not sure Opensearch works on 2.4.2 or not, but you should use Opensearch 1.2 instead of 2.x

4
  • If this answer works as your expected, please mark it as accepted, it makes it easier for others with the same issue to find a verified answer.
    – Tu Van
    Nov 3, 2022 at 16:38
  • Not the easiest job to downgrade on mac using brew, but it is what it is. Thank you
    – kotsios
    Nov 4, 2022 at 10:42
  • @kotsios would you mind sharing how you did it though?
    – Louis B.
    Feb 17, 2023 at 10:02
  • 1
    hey @LouisB., I ended up uninstalling everything related to elasticsearch and opensearch and install Elasticsearch again. If I'm not mistaken I've followed these instructions: elastic.co/guide/en/elasticsearch/reference/current/targz.html
    – kotsios
    Feb 18, 2023 at 13:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.