Error 503 Backend fetch failed

Backend fetch failed Guru Meditation:

XID: 32790

Varnish cache server

After varnish and configuration, error 503 occurred during the visit. The following are my related configuration screenshots, who can help me see where the problem is? Thank you in advance.

enter image description here

enter image description here

enter image description here

enter image description here

  • I forgot to mention that my nginx is port 8080 and varnish is port 80
    – Bob
    Nov 3, 2022 at 9:59

4 Answers 4


There can be several reason for this issue, I solved this by completely removing the below line


There are several documents available online for this issue, Pls check if any of these helps

https://magentip.com/magento-2-error-503-backend-fetch-failed-with-varnish-cache/ https://experienceleague.adobe.com/docs/commerce-knowledge-base/kb/troubleshooting/miscellaneous/troubleshooting-503-errors.html?lang=en


Run varnishlog -g request -q "ReqUrl eq '/health_check.php'" to figure out why it's failing. Please add the output from the logging transaction to your original question.

Based on the logs we'll try to figure out what's going on.


Please check your logs to identify the actual reason of error and check the VCL configuration.

Either there could many possible reason but first check varnish health:

Wrong health_check.php location in Varnish config file

Go to Varnish configuration file (/etc/varnish/default.vcl) and find these lines

.probe = {
    .url = "/pub/health_check.php";

Change it to

.probe = {
    .url = "/health_check.php";

This is the error could be the possible two situations:

  • Varnish is not able to fetch the response from Magento due to configuration issues There is an issue on Magento's side.
  • Magento sends 5xx HTTP response code.

To Fix Magento Issue

Usually, they are about some file permissions. In order to find exact issue, you need to skip varnish and visit the web server directly

Please check:




For me this issue got resolved when i disabled magento csp module in local

php bin/magento module:disable Magento_Csp
php bin/magento c:f

Not the answer you're looking for? Browse other questions tagged or ask your own question.