2

I can't access the magento 2 admin panel after upgrading from version 2.4.0 to version 2.4.3. I have followed all the steps and cleared all the caches but I can't get in. Instead, the frontend works fine.

Error is: (BadMethodCallException): Missing required argument $authorizationChecks of Magento\Customer\Model\Customer\AuthorizationComposite

I attach a screenshot of the error.

Thank you all!

enter image description here

2 Answers 2

0
  1. Try to disable Magefan_Community module and check if the issue is resolved.

  2. If the issue persists, try to disable Bss_CustomOptionAbsolutePriceQuantity module and check if the issue is resolved.

  3. If the issue persists, run the following command to find which module call AuthorizationComposite class

grep -r AuthorizationComposite app vendor

then add the result to your question. I'll continue help you to fix this issue.

0

Please disable the Bss_CustomOptionAbsolutePriceQuantity module and run the di compile command.

php -d memory_limit=-1 bin/magento s:d:c

Error is saying you have an invalid sequence in conductor params, please follow the same sequence from a parent class and variable with values are placed last. like $data, $arrayVar = [], etc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.