0

I would like to know recomendations on migration, I ant to upgrade magento 2.4.2-p2 to the latest version. But not sure if I should upgrade to magento 2.4.5-p1 2.4.5 2.4.4-p2 2.4.4-p1 2.4.4 2.4.3-p3 2.4.3-p2 2.4.3

As I notice that these new versions of magento use a more advance php version. And Im not sure if I can just skip to the latest or I need to do minor upgrades first.

Also I understand this are the commands for upgrade:

composer remove magento/product-community-edition --no-update composer require-commerce magento/product-community-edition 2.4.5-p1 --no-update --force-root-updates rm -Rf vendor composer update

Thanks

2 Answers 2

2

You can upgrade straight forward from 2.4.2-p2 to 2.4.5-p1.

Since magento 2.4.4 requires PHP code to compatible with PHP 8.1, you might need to resolve some issues to make sure your project works as expected.

1

Before upgrading the version just check your 3rd party modules which all are supporting 2.4.5 version cause its just out in august. Magento 2.4.4-p1 is currently more stable and supported by 3rd party vendors.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.