0

I have upgraded to 2.4.5 and run UCT tool but shows los of error related to core file Ex: Extending from class 'Magento\Framework\App\Helper\AbstractHelper' that is non API on version '2.4.5' Using class 'Magento\Shipping\Model\ShipmentNotifier' that is non API on version '2.4.5'

1 Answer 1

0

These files are in magento codebase (core), so you don't need to fix them. If you still would like to fix these issues, mark that class as @api in docblock.

Example:

/**
 * Schema object for a GraphQL endpoint describing queries and types for a client to consume.
 *
 * @api
 */
class Schema extends \GraphQL\Type\Schema
{
}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.