1

When trying to create an order from the admin panel, I get a page without menus/headers:

enter image description here

I tried:

php bin/magento cache:clean php bin/magento cache:flush

php bin/magento setup:di:compile php bin/magento indexer:reindex

php bin/magento setup:static-content:deploy -f

that didn't change anything, I also checked the logs, but didn't find anything...

Any help is appreciated, thanks!

2 Answers 2

0

View the page source, sometimes the PHP Exception is hidden from the page in a script tag or something.

Also check for any CSS files in the request tab of Chrome developer tools. You may find the style sheets are 404'ing, sometimes due to permission issues.

1
  • I just get a lot of those errors: Uncaught ReferenceError: require is not defined <anonymous> example.com/sales/order_create/index/:881 but there's no css at all - it doesn't load them I gues...
    – Gork
    Sep 27, 2022 at 8:25
0

When you get a partially-rendered, unstyled page like this in Magento, it usually means some business logic crashed. The most likely cause is a faulty customization, whether in your own app/code/{Namespace} directory or in a third-party module or theme.

You've got a couple of options.

  1. If you're using an IDE with Xdebug, you can set a breakpoint in \Magento\Sales\Controller\Adminhtml\Order\Create\Index. For example, you could set a breakpoint on $this->_initSession() and step through until you find where the code breaks.

  2. If you don't have access to debugging tools, you can try disabling custom themes, or custom modules that might modify Magento's sales operations. This is a tedious process, but is likely to lead (eventually) to the problem code.

In either case, assuming this is not a brand-new installation and that creating an order has worked up until now, save yourself some time by starting your bug hunt with recent installations or changes.

I wish I had a magic bullet for you, but there's nothing for it but some good old-fashioned detective work. Good luck!

UPDATE [9/27/22] Based on your response to Luke, it does indeed sound like you have bad code somewhere. That error message ("Uncaught ReferenceError: require is not defined") makes me think RequireJS is not implemented correctly on this page. Meetanshi gives an example of what a RequireJS implementation should look like.

I still think your best bet will be continue disabling third-party or custom modules/themes until you find the one that's breaking. Alternatively, you could look specifically for phtml files (probably) that are attempting to use RequireJS wrongly.

6
  • I tried disabling extensions, but so far no luck - as mentioned above, there's no css or other html tags - no head, no body, just the <form> tag
    – Gork
    Sep 27, 2022 at 8:28
  • I've updated my comment based on your response to Luke.
    – kookaburra
    Sep 27, 2022 at 12:12
  • Ok - until now I had no luck with third-party modules... Where is the "Create New Order" phtml located - or is there a separate file for the admin create order? Thanks!
    – Gork
    Sep 27, 2022 at 15:47
  • I believe this is the foundational file: vendor/magento/module-sales/view/adminhtml/templates/order/create/data.phtml. But really, it's highly unlikely something is wrong in this file unless someone went in there and edited it directly. It's more likely that someone has overridden this file or one of its children.
    – kookaburra
    Sep 27, 2022 at 16:44
  • Yeah, I thought I could do a search to find if another file exists or search my 3rd party modules for overrides but until now I found nothing suspicious... In the data.phtml file is only the <div class="page-create-order"> stuff, no header or includes - is that correct? Thank you!
    – Gork
    Sep 28, 2022 at 16:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.