1

I am facing the following issue on elastic search.

TOO_MANY_REQUESTS/12/disk usage exceeded flood-stage watermark, index has read-only-allow-delete block

I tried “cluster.routing.allocation.disk.threshold_enabled” : false & “index.blocks.read_only_allow_delete”: null but still I get the same issue

How to check free space available and the path of the elastic search storage?

I tried df -h but I am not sure where the path is located. rehel-root shows 98%, Is that the path linked to elastic search?

enter image description here

1 Answer 1

0

This path is linked to Elasticsearch, By doing curl -XGET 'http://localhost:9200/_cat/allocation?v' you will see the free space available at Elasticsearch.

enter image description here

Total 49.9GB of disk on the root path that mapping df -h directory /, 98% of space used.

I cleared a few spaces and it's working now, Have to allocate space or move the project to /DATA where 2.9TB is available.

enter image description here

We have three states on Elasticsearch Disk Watermark, Based on your config file this will show, the Flood state is the one where read_only_allow_delete will be enabled by Elasticsearch

  • Low disk watermark
  • High disk watermark
  • Flood stage disk watermark
PUT _cluster/settings
{
  "transient": {
   
    "cluster.routing.allocation.disk.watermark.low": "85%",
    "cluster.routing.allocation.disk.watermark.high": "90%",
    "cluster.routing.allocation.disk.watermark.flood_stage": "95%",
    "cluster.info.update.interval": "1m"
  }
}

For more details, you can refer to the link.

https://opster.com/guides/elasticsearch/capacity-planning/elasticsearch-disk-watermark/
https://opster.com/guides/elasticsearch/capacity-planning/elasticsearch-high-disk-watermark/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.