0

I've upgraded the Magento-EE from 2.4.3-p3 to 2.4.5, after the successful upgraded the application working fine.

But while doing setup upgrade it's showing the following error .

Base table or view not found: 1146 Table 'demo.patch_list' doesn't exist, query was: SELECT `patch_list`.`patch_name` FROM `patch_list`

Our Finding:

In Magento-2 OOTB, I saw the following declarative schema in db_schema.xml file under the app/etc directory.

but the code does not in our application code. If i add this code and ran the upgrade command, it's showing lot of duplicated entry problem in our Magento Core table.

<table name="patch_list" resource="default" comment="List of data/schema patches">
        <column xsi:type="int" name="patch_id" identity="true" comment="Patch Auto Increment" />
        <column xsi:type="varchar" name="patch_name" length="1024" nullable="false" comment="Patch Class Name" />
        <constraint xsi:type="primary" referenceId="PRIMARY">
            <column name="patch_id" />
        </constraint>
    </table>

So we need some better solution to fix the problem, thanks in advanced for your better support.

1
  • Hi there , check if the version upgrade is successful by deleting the vendor directory and run the composer install once again expecting it should not result in any errors and module responsible for installing this table = patch_list which is Magento2-base is installed properly or not.Please do reply and educate us if you have found out a solution.Thanks. Sep 22 at 18:32

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy