I'm using Magento 2.4.3. For some reason, guest checkout is still allowed, even after selecting the Allow Guest Checkout = No setting in the backend. It doesn't show the "Guest checkout is disabled" message anymore. It was working for a while, and then, it seemed to randomly stop working. I have tried changing the setting to Yes and then back to No and then re-indexing and clearing the cache, but guest checkout is still allowed. Any ideas?

  • Hi, Try checking the configurations in all store views scope as that field has that feasibility for store views, and try checking in browsers incognito mode also one time.Thanks Commented Sep 20, 2022 at 4:40
  • The configuration for all store views has also been changed between the different options without success. Incognito mode still has the same result.
    – n00b
    Commented Sep 20, 2022 at 18:09

1 Answer 1


still no answer to this? Finding myself in a similar situation at the moment.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.