0

I am upgrading Magento CE from 2.4.3-p1 to 2.4.4-p1 with php 8.1 but I got this problem facebook/graph-sdk does not support php 8.1 and it is PHP package not Magento 2 Module,

facebook/graph-sdk 5.6.2 requires php ^5.4|^7.0 -> your PHP version (8.1.8) does not satisfy that requirement.
- facebook/graph-sdk 5.6.1 requires php ^5.4|^7.0 -> your PHP version (8.1.8) does not satisfy that requirement.
- facebook/graph-sdk 5.6.0 requires php ^5.4|^7.0 -> your PHP version (8.1.8) does not satisfy that requirement.
- facebook/graph-sdk 5.5.0 requires php ^5.4|^7.0 -> your PHP version (8.1.8) does not satisfy that requirement.
- facebook/graph-sdk 5.4.4 requires php ^5.4|^7.0 -> your PHP version (8.1.8) does not satisfy that requirement.
- facebook/graph-sdk 5.4.3 requires php ^5.4|^7.0 -> your PHP version (8.1.8) does not satisfy that requirement.
- facebook/graph-sdk 5.4.2 requires php ^5.4|^7.0 -> your PHP version (8.1.8) does not satisfy that requirement.
- facebook/graph-sdk 5.4.1 requires php ^5.4|^7.0 -> your PHP version (8.1.8) does not satisfy that requirement.
- facebook/graph-sdk 5.4.0 requires php ^5.4|^7.0 -> your PHP version (8.1.8) does not satisfy that requirement.

so my question is : how can I move this package to another directory like app/code and force using it after that I can fix bugs related to PHP 8.1

thanks in advance

2 Answers 2

0

Did you try to following already?

composer install --ignore-platform-reqs

or maybe just

composer install --ignore-platform-req=php

When this is not the solution for you can indeed move it to app/code. Check the exact folder names in registration.php.

Example:

Acme_Module becomes app/code/Acme/Module/<module files>

1
  • thanks Akif, nut it wont work because facebook/graph-sdk is not a magento module it doesnt contain registration.php
    – lazy_coder
    Sep 15, 2022 at 7:14
0

To add it to local I used this syntaxe in composer.json

under repositories

"repositories": {
   "0": {
        "type": "composer",
        "url": "https://repo.magento.com/"
    },
    "facebook.local":{
        "type": "path",
        "url": "./packages/facebook/graph-sdk"

    },

}

after that I moved the content of php-graph-sdk to packages/facebook/graph-sdk and added support to php 8.1 finally I run composer update. after that it is working fine

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.