1

We've took over a magento store. Whenever I try to update, I'm getting the following errors:

  Problem 1
    - magento/inventory-composer-installer 1.1.0 requires composer-plugin-api ^1.1 -> found composer-plugin-api[2.2.0] but it does not match the constraint.
    - magento/product-community-edition 2.3.4 requires magento/inventory-composer-metapackage 1.1.4 -> satisfiable by magento/inventory-composer-metapackage[1.1.4].
    - magento/inventory-composer-metapackage 1.1.4 requires magento/inventory-composer-installer 1.1.0 -> satisfiable by magento/inventory-composer-installer[1.1.0].
    - Root composer.json requires magento/product-community-edition 2.3.4 -> satisfiable by magento/product-community-edition[2.3.4].

I've tried removing the composer.lock file however it didn't change anything. Any help would be appreciated.

1 Answer 1

2

Magento 2.3 still requires a composer version below two (so 1.x.x) Try downgrading your composer with the following command and try again

composer self-update --1
(maybe you have to use sudo composer self-update --1 if you are on UX system, eg Linux or Mac)

Afterwards if you need to go back to version 2 of composer, use the same command just replace the version composer self-update --2

2
  • Thank you. I've assumed my hosting company was using both versions since using composer 2 requires to use 'composer2' in cli. Sep 2, 2022 at 12:59
  • Maybe it was like this until recently. But glad it's now working for you Sep 2, 2022 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.