1

I am getting a 404 error when trying to go to my admin page was working fine earlier today. Haven't changed anything since I last logged in and the only thing I was doing was assigning products to categories.

http://mytempsite.net/gotie/admin

WHAT IVE TRIED SO FAR
Delete the following file:-

app/etc/use_cache.ser <-- I could not find the file in ftp or ssh

then tried doing this Opened PhpMyAdmin
- Went to my database
- Clicked SQL
- Ran the following SQL Query:

SET FOREIGN_KEY_CHECKS=0;
UPDATE core_store SET store_id = 0 WHERE code='admin';
UPDATE core_store_group SET group_id = 0 WHERE name='Default';
UPDATE core_website SET website_id = 0 WHERE code='admin';
UPDATE customer_group SET customer_group_id = 0 WHERE customer_group_code='NOT LOGGED IN';
SET FOREIGN_KEY_CHECKS=1;

  • 1
    Cache settings were moved out of the serialized file and into the database as of CE 1.4. – benmarks May 9 '13 at 19:15
  • and that means what to me...? – Nick Darley May 9 '13 at 19:18
  • 2
    "app/etc/use_cache.ser <-- I could not find the file in ftp or ssh" That's why you can't find it. – benmarks May 9 '13 at 19:27
  • 1
    This sounds like a typical 404 ACL error, but I dont think thos is one – Fabian Blechschmidt May 9 '13 at 20:05
  • 1
    Are you getting the Magento 404 page, or the usual 404 page from the server? If it's the usual 404 page you can try to use /index.php/admin. mod_rewrite might be disabled on the server. – Marius May 9 '13 at 21:25
5

First, are you the only admin user?

Second, In your app/etc/local.xml, look for:

<admin>
    <routers>
        <adminhtml>
            <args>
                <frontName><![CDATA[admin]]></frontName>
            </args>
        </adminhtml>
    </routers>
</admin>

Does it say admin or something else?

Third, go in your core_config_data table and try to locate these variables (lines 226 + 229):

admin/url/custom admin/url/custom_path

core_config_data

Do you have any caching enabled, or have any redirects setup? Delete the Cache manually (var/cache/).

I would enable your server logs (a quick look at GoDaddy has this tutorial showing how to do it: Working with Error Logs

Attempt to turn on Magento Logging (it should be on for dev sites). You can do this by going into "core_config_data" and look for a dev/log/active. It should be set to 1 for logging (yours is probably set to 0).

Logging

I would also go further and turn on Developer Mode (which should also be on for dev sites). You can do this by going to your index.php file and changing this:

if (isset($_SERVER['MAGE_IS_DEVELOPER_MODE'])) {
Mage::setIsDeveloperMode(true);
}
#ini_set('display_errors', 1);

to this:

//if (isset($_SERVER['MAGE_IS_DEVELOPER_MODE'])) {
Mage::setIsDeveloperMode(true);
//}
ini_set('display_errors', 1);

After talking to the user, it turns out it was a file error. I referred him to setup a Diff of his core files and setup a version control system.

  • only admin user, yes. second yes it says exactly that. Third Secure and Unsecure are mytempsite.net/gotie I dont have admin/url at all in the table – Nick Darley May 9 '13 at 18:48
  • Did you do any kind of server changes recently? Are you using any kind of tool to update your products (like Magmi)? Do you see anything on your server access/error logs? Go ahead and remove everything in var/cache/. – kab8609 May 9 '13 at 18:55
  • nope system logs isn't turned on.. and no this is a site I am building so everything is entered manually and its hosted on a VPS by GoDaddy, but i haven't touched the server configs. Edit: i haven't looked at my actual server logs yet. – Nick Darley May 9 '13 at 19:00
  • Server Error - [Thu May 09 14:05:48 2013] [error] [client 24.XXX.26.XXX] File does not exist: /home/csavello/public_html/crossdomain.xml this happens every 13 seconds – Nick Darley May 9 '13 at 19:06
  • I added on the answer to show you how to enable Magento logging through phpMyAdmin. Do you have your code on version control? I can't tell yet if this is a server issue or not. Although I have heard horror stories about people attempting to get Magento to work on GoDaddy. – kab8609 May 9 '13 at 19:10
0

make sure that your apache .htaccess are enabled

refer link when you are using ubuntu 15.x: https://askubuntu.com/questions/48362/how-to-enable-mod-rewrite-in-apache

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.