0

I recently downgraded magento commerce from 2.4 to 2.3.5p2 due to having some known issue, but after the change my

Stores > Settings > Configuration

appear only below config

enter image description here

it should not appear as the image above but instead as below

enter image description here

I have disabled elasticsearch

I have run necessary command to install

  • bin/magento setup:upgrade
  • bin/magento setup:dicompile
  • bin/magento indexer:reindex
  • bin/magento cache:clean

I have give necessary read, write, execute access

I have run composer install and update

I have check on the user role and currently its been given Administrator role, so I expect it to gain full privileges

I already check on log but there is no error appear when the admin configuration page is being accessed

Please advice or guide ways that I can check and solve this problem

5
  • Do you have anything in Browser console? And meanwhile rename your app/code folder to remove all the custom code and see. Other things in admin and fronted working fine? Commented Aug 5, 2022 at 10:03
  • Please provide a way (code, etc) how you try to add image above Commented Aug 6, 2022 at 23:09
  • Hi @VictorTihonchuk the first image appear on magento commerce, the second image is from magento community, when trying to change from magento community to magento commerce suddenly the configuration appear only like the first image Commented Aug 9, 2022 at 7:26
  • Hi @JohnFonseka seems like other things in admin and frontend is working fine, just the configuration is missing in admin, I have tried disabling all added module through app/etc/config.php and surprisngly the configuration field finally appear in admin panel, it must be one of the module causing this issue but I am not sure how to track which module is causing this issue Commented Aug 9, 2022 at 7:28
  • Hi, I have able to fix the issue, turns out one of the module is causing an issue, I have tried try an error disabling 1 by 1 and a custom module is causing the error, have fixed an error inside the custom module which is caused by redundant layout file , now its okay Commented Aug 10, 2022 at 1:11

2 Answers 2

0

I have the same issue and I found the ShipStation integration by Auctane is the problematic module but I have no idea how to fix it. Can you please provide more specific details on how to fix it?

1
  • You would need to go to app/etc/config.php path and remove the said module, I assume your module name is Auctane_ShipStation, set it to 0, if still unable to , rename the entire folder of that module and run all necessary command ( upgrade, compile, clear cache ) Commented Aug 21, 2023 at 9:09
0

@Mohd Farhan Bin Ramli

Hey,

  1. Check Admin Role Permissions
  2. Clear Cache
  3. Reindex
  4. Check for Module Issues
  5. Run Setup Upgrade & check logs

Follow the above steps, Thank You!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.