1

On upgrading to Magento 2.4.4 got this error on running setup:upgrade command

Class "Magento\Framework\Communication\Config\Reader\XmlReader" does not exist

This class is not used in any of the custom modules

The class is present in vendor/magento/framework/Communication/Config/Reader/XmlReader.php

2 Answers 2

2

I would firstly clear the generated folder, delete the vendor folder, run composer cc && composer install and then run setup:upgrade

2
  • 1
    Yupp...for some reason container-interop directory was missing inside vendor. So deleting the entire vendor directory and running composer install worked
    – GenZ Dev
    Commented Jul 28, 2022 at 5:28
  • Any ideas why this would not work? I tried and same error. I have 2.4.5-p1.
    – Webninja
    Commented Jan 13, 2023 at 19:47
0

For me the solution was to download the 2.4.5-p1 version's original app/etc/di.xml file and copy that to my installation and then run setup:upgrade again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.