1

I am unable to submit a new module or update a existing module in the Magento Marketplace.

For all modules/new versions, I get the error during the Technical Review at the Installation & Varnish Test stage. Error from report.json:

ERROR: [11] The command "php ./bin/magento module:enable --all --ansi --no-interaction" failed. Warning: require(/app/setup/config/application.config.php): failed to open stream: No such file or directory in /app/vendor/magento/framework/Console/Cli.php on line 78
returned non-zero exit status 11

The error occurs when executing different commands, not only for php ./bin/magento module:enable --all --ansi --no-interaction, but the error is always the same.

I couldn't reproduce it locally on different versions of Magento, PHP and composer.

In my opinion, this looks like a problem with the environment in which the modules are tested.

1
  • I had the same problem and opened a ticket with Magento support. A couple of hours ago I suddenly got a run saying a submission which had already failed automated testing, had now passed. So I think they might have fixed it. Jul 14 at 7:27

2 Answers 2

1

Since 1st July 2022 composer began imposing some security requirements on plugins and for your application, there are below four plugins that need addressing:

Try to run below command and commit the changed composer.json file.

composer config --no-plugins allow-plugins.magento/magento-composer-installer true
composer config --no-plugins allow-plugins.magento/inventory-composer-installer true
composer config --no-plugins allow-plugins.magento/composer-root-update-plugin true
composer config --no-plugins allow-plugins.laminas/laminas-dependency-plugin true
8
  • thanks for the reply. I'll try to add settings to composer.json of the module. Although it confuses me that the allow-plugins setting was added only in composer 2.2, and the requirement for the Magento 2.4.4 is composer 2.1. Magento 2.4 requirements. Have you already encountered a similar problem, or do you just assume that it can help?
    – Victor S.
    Jul 9 at 19:56
  • Yes, I've encountered with the same error in Magento Cloud environment Jul 9 at 19:58
  • Then I will try to publish the module and if it works, I will mark it as a solution.
    – Victor S.
    Jul 9 at 20:07
  • I also asked the same question on stackoverflow.com. You may want to post your answer there as well.
    – Victor S.
    Jul 9 at 20:48
  • Please confirm the issue was solved first Jul 9 at 20:51
0

As I understand, the problem was on Magento Marketplace side.

There is news in #marketplace Slack channel that the problem has been fixed:

Hi all,
The issue with “allow-plugins” in 2.3 is fixed now.
Right now we are going to rerun tests for all affected submissions.
Sorry for inconvenience and Thank You all for being patient.

1
  • Finally, I was right about the issue was related to allow-plugins Jul 21 at 10:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.