1

After upgrade Magento 2.4.2 to 2.4.4 search functionality is not working due to elastic search.

Even category products are showing fine. I have done reindex , cache flush , setup upgrade.

In log i am getting below details .

[2022-07-06T03:29:18.028510+00:00] main.CRITICAL: Elasticsearch\Common\Exceptions\BadRequest400Exception: {"error":{"root_cause":[{"type":"query_shard_exception","reason":"[match_phrase_prefix] analyzer [prefix_search] not found","index_uuid":"y4Js58-bRZyQPFUqodoBRg","index":"magento2_product_1_v25"}],"type":"search_phase_execution_exception","reason":"all shards failed","phase":"query","grouped":true,"failed_shards":[{"shard":0,"index":"magento2_product_1_v25","node":"GN_pI799Tl2S6unB-agkfw","reason":{"type":"query_shard_exception","reason":"[match_phrase_prefix] analyzer [prefix_search] not found","index_uuid":"y4Js58-bRZyQPFUqodoBRg","index":"magento2_product_1_v25"}}]},"status":400} in /vendor/elasticsearch/elasticsearch/src/Elasticsearch/Connections/Connection.php:693
2
  • Did you manage to solve it? Sep 28, 2022 at 10:18
  • I am also facing same issue? Did you find solution for this issue
    – Vino
    Jul 7, 2023 at 12:28

3 Answers 3

0

You should use ElastiSearch 7 , And

you want to check

Stores > Settings > Configuration > Catalog > Catalog > Catalog Search >
elastic server > test connection button.

you can check which search engine :

bin/magento config:show catalog/search/engine
bin/magento config:set catalog/search/engine elasticsearch7

and also check in database "core_config_data" : path = "catalog/search/"

if you have some custom attributes in catalog, you should 
include them in the search so they can be properly indexed.
0

Run below command in your cmd and then run re-indexing command

curl -XDELETE localhost:9200/*

Replace localhsot and port(9200) with your host and port

0

you also can fix this by setting Configuration->Catalog->Catalog Search->Search Engine to none. https://xxxxx/admin/system_config/edit/section/catalog/

Do not forget to reindex and clear cache.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.