0

When I try to modify system.xml or add a product attribute, I try to run setup:upgrade, cache:flush or setup:di:compile. Why might the Magento admin site still not reflect the change in content that I already added?

3 Answers 3

0

Do try these and check on incognito

rm -rf pub/static/*
rm -rf generated/*
rm -rf var/view_preprocessed/*
rm -rf var/cache/*
php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento setup:static-content:deploy -f
php bin/magento cache:flush
3
  • It still not working but thank for your help
    – KAITO_3SS
    Jul 5, 2022 at 4:59
  • Could you check for any exceptions/errors in /var/log and let us know ? also silly question: are you editing and running all your commands on the same project root ? I occasionally do this mistake :D
    – Rejith
    Jul 5, 2022 at 5:23
  • Well, it realy hard for me to tell you what my problem is but i can only say that my magento project has a bizarre problem that when i run the command line, my site does not change at all, i check on google and nobody has this issue before. So i hope you can understand it.
    – KAITO_3SS
    Jul 5, 2022 at 6:01
0

If you add attribut to product you probably need to reindex your catalog data

php bin/magento i:rei

you can also try to force the update of the attribut :

php bin/magento queue:consumers:start product_action_attribute.update

What kind of change do you want to make?

0

You should try this steps :

- rm -rf var/cache/* var/page_cache/* var/generation/*
- sudo chmod -R 777 var/ generated/
- Composer update 
- Restart fpm php
- bin/magento setup:static-content:deploy -f
- If you are doing custom work then you should check the directory path.

If you are still facing the same do let me know!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.