Recently we updated magento version from 2.2 to 2.3.x , All the catalog , orders , customers working fine but when we save data from Store-->Configuration , Data is saving finely in database but the values are not reflecting on Admin Panel UI.

For example , I want to enable "Single Store Mode" to "Yes" , In database it is saving as 1 but in admin panel , The setting showing as "No" as selected. I have only one store and one website in magento stores.

I tried below methods.

  1. Cache Flush
  2. Removed var/cache and var/sessions
  3. Did indexer

But none of them worked for me.

1 Answer 1


I have faced this in some Magento 2.3.x projects. I believe it only happens in some concrete versions

It is a weird issue, as it only happens sporadically. You can try this https://magento.stackexchange.com/a/223981/3566

If that doesn't solve the problem, you could try moving both cache & sessions to Redis. After that we've never experienced it again. More info https://devdocs.magento.com/guides/v2.4/config-guide/redis/config-redis.html

  • I tried your answer but no use of it. Any other debug technique?
    – Dinesh
    Jun 21, 2022 at 2:04
  • Is it related to github.com/magento/magento2/issues/23133 this?
    – Dinesh
    Jun 21, 2022 at 5:10
  • You could try upgrading to latest 2.3.x version Jun 21, 2022 at 8:48
  • That is also not working... Any other debug techniques?
    – Dinesh
    Jun 22, 2022 at 10:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.