0

enter image description here

enter image description here

The log in the report is this.

a:4:{i:0;s:97:"The requested component ("settings") is not found. Before using, you must add the implementation.";i:1;s:9651:"#0 /home/u783663984/domains/ukmadesweets.co.uk/public_html/vendor/magento/module-ui/Model/Manager.php(207): Magento\Framework\View\Element\UiComponent\Config\Provider\Component\Definition->getComponentData('settings')

Does anyone know the fix for this. I am a beginner so would appreciate some instructions as I cant access my Categories in the Admin pannel at the moment.

Thank you

1 Answer 1

0

Seems like you are using a new module (not compatible with <= 2.2 Magento version) with the old Magento. Since 2.2 the <settings> added to the definition list of ui components, but in the old version you had to use argument/data/config. Try to find this module in the project using search (by string <settings>) and disable it. After that - clear the cache and try to open the categories menu, it should work.

The better solution would be to update your Magento to the latest version 2.4.4, but this can be very difficult (from 2.1.x to 2.4.x).

Old definition without <settings>: https://github.com/magento/magento2/blob/2.1/app/code/Magento/Ui/view/base/ui_component/etc/definition.xml

New one (part) with the <settings> definition for elements: https://github.com/magento/magento2/blob/2.2/app/code/Magento/Ui/view/base/ui_component/etc/definition/ui_settings.xsd

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.