0

We are using Magento CE 1.9. I am having a problem. I am trying to enable backorders with customer notification. I have set

System - Configuration - Inventory - Product Stock Options - Backorders" set to ""Allow Qty Below 0 and Notify Customer" for every product I have set Manage Stock to "Yes" Stock Availability to "In Stock"

Backorders are accepted, but there is no notification in the cart associated with the products that are backordered.

All products visible in the catalog are configurables.

My question is a two-part one. First, am I doing something wrong? I.e. is there something else I need to set up?

Second, if I'm doing everything right where would I look for the code that should be producing this notification?

2

About the second part of your question https://www.alphachannelgroup.com/magento-backorders-complete-with-notifications-to-customers/

Modify Your Theme File to Display a Custom Backorder Message

In [your theme]/[your_theme]/template/catalog/product/view/type/default.phtml

Add echo $backorder_message; right after the endif of the section that starts with // Backorder message comment

(EDITED OUT)

About the first part of your question try the following steps (you have done some of these, but still):

  1. Admin Panel > System > Configuration > Catalog Tab > Inventory > Product Stock Options
  2. Set Backorders to "Allow Qty Below 0 and Notify Customer"
  3. Edit Product to Qty to the number of current in-stock quantity (or 0 if there are no quantities for this product in stock)
  4. Set Stock Availability = In Stock
  5. Set Manage Stock to "Yes"
  6. Set Qty for Item’s Status to Become Out of Stock to negative number of the backorder availability (e.g. the number up to which you want to allow back ordering)

    UPDATE core_config_data SET value = ‘-100’ WHERE path = ‘cataloginventory/item_options/min_qty’

Sources:

http://blog.chapagain.com.np/magento-how-to-enable-backorders/

http://www.magentocommerce.com/boards/viewthread/288259/

http://www.magentocommerce.com/knowledge-base/entry/configuring-inventory-information

  • The System => Configuration => etc. is set up properly. I think the problem may be a sort of Catch-22. Although I set up all of my products with "In Stock" Stock Availability, as they are depleted and the Qty falls below 0 they are marked "Out of Stock" automatically. I wonder if I could set the Qty for Item's Status to Become Out of Stock to a large negative number. – Dave Schuler Sep 3 '14 at 18:53
  • They fall bellow 0, because you have manage stock = yes. Set it to No and try again. See magentocommerce.com/knowledge-base/entry/… - idea is to make product permanently available but as backorderable product – Zlatin Zlatev Sep 4 '14 at 8:59
  • But if we turn off stock management don't we completely lose track of stock? We want to take backorders on stock that's being maintained, not eliminate stock management entirely. – Dave Schuler Sep 4 '14 at 10:05
  • OK, in this case, set negative value for "Qty for Item’s Status to Become Out of Stock" magentocommerce.com/boards/viewthread/288259 and try again. Edited out the answer to include this discussion so far. – Zlatin Zlatev Sep 4 '14 at 10:52
  • Okay I'll give that a try. – Dave Schuler Sep 4 '14 at 12:42
0

Go to system > configuration and on the left side panel click on inventory tab under Catalog tab and then open product stock option section and set Heading BackOrders drop down menu to ALLOW QTY BELOW 0 AND NOTIFY CUSTOMER

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.