0

I'm getting this error that mycrypt is deprecated. I've heard I should use openssl. But I'm not sure how would I go about this in terms of my Magento 1.9 setup. Can I get some insight? Also how serious is this problem?

ERR (3): Deprecated functionality: Function mdecrypt_generic() is deprecated in /home/customer/www/sciencellonline.com/public_html/lib/Varien/Crypt/Mcrypt.php on line 130

Thanks

2 Answers 2

1

You can migrate vanilla Magento 1 to OpenMage 19 or 20 which is an active project on GitHub. This issue was solved long time ago.

0

Switch to a PHP version <=7.1. Higher versions are not compatible with your Magento version.

More info: https://www.php.net/manual/en/function.mdecrypt-generic.php

2
  • Hello. Unfortunately, I cannot switch back to an older php version either. Is there another way?
    – Zei
    Jun 13 at 22:28
  • You should run a script which checks for compatibility of PHP version and fix all issues in the code. I think companies like MageOne provide patches to make M1 compatible with newer php versions. You can also look into that Jun 13 at 22:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.