0

So as the title states, after just installing Magento 2.4.3 using the following guide:

https://www.simicart.com/blog/how-to-install-magento-2-localhost/

I was met with just the HTML render of the page, both on the frontend and admin panel. I tried bin/magento setup:static-content:deploy -f as per someones instructions. I have also tried removing the sample data and executing the following commands:

php bin/magento setup:upgrade
php bin/magento setup:static-content:deploy -f
php bin/magento cache:clean

But those did not wield any result either.

As a note, I am very new to Magento (this being my first taste) so the solution might be fairly evident to some but maybe not to me.

Thank you for your help, have a great day!

Edit:

Here are some screenshots of what I mean: enter image description here

enter image description here

I also changed all the folder and file permissions from read-only but still does not work.

9
  • have you checked the permissions of your files/directories?
    – ljr95
    May 23, 2022 at 13:23
  • What do you mean with "just the HTML render of the page"? May 24, 2022 at 8:06
  • Can you please provide more screenshots ? May 24, 2022 at 8:30
  • @BharathKumarJ I did edit to show some screenshots.
    – LittleDTLe
    May 24, 2022 at 8:42
  • @RaulSanchez I did edit to show some screenshots.
    – LittleDTLe
    May 24, 2022 at 8:42

1 Answer 1

1

For this issue, there is a solution:-

  1. Please find the table core_config_data for this project.
  2. Search for the path - "use_in_adminhtml" and make the value empty or NULL in MySQL.
  3. Again search for the path - "use_in_frontend" and make the value empty or NULL in MySQL.
  4. Run the deployment commands like "bin/magento s:up" and refresh the page.
  5. Your issue will be solved.
  6. If it is not solved , please post your queries again.

enter image description here

Thanks, and please let me know here if this solves.

5
  • When I run the SELECT query the table returns empty, so I tried to search for the path values manually but I cannot find the path values that way either. The only result I get in "path" that has "use" is "use_rewrites".
    – LittleDTLe
    May 25, 2022 at 9:54
  • Also here is a screenshot of what I mean: prnt.sc/ul-q0oNzH3M2
    – LittleDTLe
    May 25, 2022 at 10:25
  • Okay, here is another guess - 1. Please remove the static URL and media URL, I came to know from the link you have followed when installing the Magento , you can just make it as NULL or empty in mysql for the paths - base_static_url base_static_url (secure) base_media_url base_media_url (secure) After that try running the Magento deployment commands again (bin/magento s:up) is enough and make sure you are in developer mode. Magento is not supported for windows and macOS , Please check this official link - devdocs.magento.com/guides/v2.4/install-gde/… May 25, 2022 at 11:02
  • That did not seem to fix it either. I tried creating another setup which has the exact same problem, but it did not get fixed there either.
    – LittleDTLe
    May 25, 2022 at 11:40
  • Then please try debugging , via various ways like:- from the browser dev tools , or you can choose to debug using the xdebug etc.All the best.Thanks May 25, 2022 at 12:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.