0

I have 3 websites:

Website 1 still runs on Magento 1.9.4. Websites 2 and 3 run on Magento 2.4.2-p1 which we are having terrible problems which I believe are because the Magento Migration Tool messed that up real good.

Now I asked our hosting company to install Magento 2.4.4 (first because it was not available in Softaculous immediately after release) and they have come back with the following:


I can see that in that ticket you requested us to install Magento 2.4.4. As this version of Magento is now added to the Softaculous Apps Installer tool, I went ahead and tried to install the requested version through the Softaculous tool.

However, the following errors were encountered: The following errors were found:

You can try installing the previous version of Magento by selecting from the "Choose Version" dropdown below

Required PHP version greater than equal to 8.1.0 AND found version is : 7.3.33

You can try installing the previous version of Magento by selecting from the "Choose Version" dropdown below

Required MYSQL version greater than equal to 8.0.0 AND found version is : 5.7.38 While we can easily upgrade the PHP version of the domain, the MySQL version upgrade is a bit more complicated as it would be upgraded for your whole server. The current MySQL version that you are using is 5.7 and if any of your existing applications are not compatible with MySQL version 8, then you risk having those application to break in order for the Magento 2.4.4 to be installed

In case you still want us to proceed and upgrade the MySQL version of your server with us - please submit a new ticket to our General Support department where my colleagues would be glad to upgrade the MySQL version of your server with us.


Is it really not possible to run these 3 Magento versions on one VPS hosting account? And what is my solution here? I need to get 2.4.4 up and running so that I can transfer customers, orders and products there from the 1.9.4 version and then I can close that down which would probably mean I could upgrade the whole server accordingly?

1 Answer 1

1

It's not possible to run these Magento instances in one Hosting with the same PHP Version. The reason is simple: Magento 1.9 was released in 2014, 8 years ago. Magento 2.4 was released in 2020. PHP has gone through an evolution during this time and new features have been introduced. And removed old functions. And that's why Magento only runs on the PHP versions they were developed for.

There are few solutions for your use case. One solution is to run Magento 1.9 on one VPS and Magento 2.4 on another VPS. Export all customers and products to a csv file and import the csv file to Magento 2.4. With this solutions, you are not able to import the orders and maybe you have to do some corrections in Excel.

Another solution is to use the magento data migration tool. Follow the steps in the readme file in the github repo. For this solution, you only need the magento 2.4 instance running and on the same server access to the magento 1.9 database.

Another solution is to write your custom import/export script.

2
  • Thank you for that. I will NEVER use the Magento Migration Tool again as it screwed up sooo many things for us - seriously, it would take hours to list them all. We might do what you suggested - CSV export/import of customers and products and get some extension somewhere to Export and Import orders.
    – Allysin
    May 13 at 23:39
  • I had troubles with the Magento Migration Tool too. I will never use the tool again. :-) instead to import the orders: in my case, we exported a simple list of the old orders from the old magento shop and displayed the list in the new magento shop in the customer account, below the new order list. just as static content without a reorder function. May 14 at 9:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.