0

i would like to know how to install Magento 2.4.4 starting from the archive with sample data.

The archive can be downloaded here: https://magento.com/tech-resources/download#archive-releases

While the docs should be here: https://devdocs.magento.com/guides/v2.4/install-gde/prereq/zip_install.html

The problem is, that link to the zip install docs redirects to the composer installation docs.

So i'm asking for a step by step guide to install it from the zip. I'm using linux mint 20.3 (ubuntu).


Thank you

2
  • Hi aetonsi after the download is complete, just unzip and go inside the unzipped directory and execute the command mentioned by S.P May 14, 2022 at 19:21
  • with the procedure by SP, and also following the official guide, i get 404 errors on every static file (js and css). what can i do?
    – aetonsi
    May 16, 2022 at 14:59

2 Answers 2

1

You need to create virtual host for magento2.4.4. And check your PHP version (must be later php7.4)

create virtualhost : https://linuxize.com/post/how-to-set-up-apache-virtual-hosts-on-ubuntu-20-04/

Install composer : https://www.digitalocean.com/community/tutorials/how-to-install-and-use-composer-on-ubuntu-20-04

Install elasticsearch: https://www.digitalocean.com/community/tutorials/how-to-install-and-configure-elasticsearch-on-ubuntu-18-04

Install magento with composer.

sudo php bin/magento setup:install --base-url="http://www.magento244.com/" --db-host="localhost" --db-name="yourdb" --db-user="youruser" --db-password="youarpassword" --admin-firstname="admin" --admin-lastname="admin" --admin-email="[email protected]" --admin-user="admin" --admin-password="admin@123" --language="en_US" --currency="INR" --timezone="America/Chicago" --use-rewrites="1" --backend-frontname="admin" --elasticsearch-host=localhost --search-engine=elasticsearch7 --elasticsearch-enable-auth=0

Install Sampledata.

sudo php bin/magento sampledata:deploy;

Execute below command and set proper permission.

sudo php bin/magento setup:upgrade;
sudo php bin/magento setup:static-content:deploy -f;
sudo php bin/magento cache:clean;

Set permission for your var pub and generated folder.

7
  • hello, i get 404 errors on every static file (css and js), thus the page is completely broken. what can i do?
    – aetonsi
    May 16, 2022 at 14:58
  • your home page load perfect right?
    – S.P
    May 16, 2022 at 15:07
  • no, the home page loads broken, with just html content. all the JS and CSS is missing
    – aetonsi
    May 17, 2022 at 13:19
  • check your server settings for <Directory /var/www/html/> Options FollowSymLinks AllowOverride All </Directory>
    – S.P
    May 17, 2022 at 13:22
  • 1
    and restart your server and execute setup:upgrade and static-content command again.
    – S.P
    May 17, 2022 at 13:22
0

I got it working via the following:

  • unzip the archive's content in /var/www/html
  • set file permissions: sudo su
    • chmod 777 . -R ; chown -R :www-data . ; chmod u+x bin/magento
  • edit apache2 config (remove 'indexes' from options, change allowoverride to all): sudo nano /etc/apache2/apache2.conf
    <Directory /var/www/html/>
        Options FollowSymLinks
        AllowOverride All
    </Directory>```
    
  • enable apache2 rewrite module: sudo a2enmod rewrite
  • restart apache service: sudo service apache2 restart
  • run elasticsearch: elasticsearch-7.17.3/bin/elasticsearch -d -p pid
  • run bin/magento setup:install following the official guide https://devdocs.magento.com/guides/v2.4/install-gde/composer.html#install-magento
  • set file permissions again: sudo chmod 777 . -R

And it is now working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.