Somehow Magento calculates an incorrect price when adding an order from the backend.

This problem only occurs on products with a custom option field and when the locale is set to a land that uses commas in prices, instead of dots.

In my case, that is Dutch.

To demonstrate the steps I take:

  1. Adding a product, goto:

    Sales -> Orders -> Create new order

  2. Click 'add product'

    Select a product with a custom option, so a popup appears. Remember to set the locale first to another one (for instance: Netherlands) before you add the custom option product, else the miscalculation won't happen.

    Adding product Magento

  3. When you click 'ok' you will see that the quantity is multiplied by 100.

    Product is multiplied

This a something strange, on a fresh installation of Magento it also occurs.

My best bet would be there is a problem with the javascript parsing the prices incorrectly, because of the format used (. instead of ,) .

I know that I can go a step further in the 'adding product' process, where you can edit the quantity. But, I still want to get this working normal for clients.

Can someone suggest the proper solution to resolve this issue?

  • Hey, could u tell me the Magento version u r using? Thanks :) Nice find, btw :D Commented Sep 16, 2014 at 21:08
  • Thanks! I think this is a problem for all Magento installations. I'm using Magento 1.8 but i also tested it out on the latest version Could you take a look at it? Hope you make some fix for this :).
    – Laurens
    Commented Sep 17, 2014 at 22:09
  • @simonthesorcerer Did you maybe found some info/fix on this one? Would certainly hope so :)
    – Laurens
    Commented Sep 29, 2014 at 21:11
  • My best bet would be that you had some weird browser caching problem with some of the javascript parsing the prices incorrectly. Have you tried to clear the browser cache after switching the language? What browser have you tried?I've tested this on a vanilla clean install of Magento v1.9.0.1 with sample data and it does not happen. Commented Feb 14, 2015 at 16:21
  • 1
    @MageComp it was also tested on a fresh install. It only occurs when u are using euro.
    – Laurens
    Commented Aug 23, 2015 at 12:58

1 Answer 1


Looks like you have got the setup wrong on your locale. Either in one of your translate.csv files or the backend administraction itself. You are correct in thinking the issue is around the , against the . Just ensure this is correctly classified in the backend and the issue should be resolved

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.