1

After installing a few extensions, they for some reason don't show up in the Connect Manager. Modules like: M2E, Jemoon_Htmlminify, Lest_FPC, PulseStorm_Launcher, etc.

They are all installed, but they are not listed there. And when I try and upgrade them (by installing them again via Connect Manager), I get this error:

CONNECT ERROR: Package 'm2epro_ebay_magento' is invalid './app/code/community/Ess/M2ePro/Block/Adminhtml/Account/Grid.php' already exists

It then halts my magento installation, until I delete the file maintenance.flag in my magento folder.

I've tried running:

  1. ./mage sync but it's not working.

What's going on here? I'm running Magento 1.9

  • Did you install all these extensions via the Magento Connect Manager? – Simon Sep 11 '14 at 10:51
  • Yes, all the extensions were installed via Connect Manager – pozitronic Sep 11 '14 at 10:52
  • Normally, each installed extension has an XML file under var/package/. Maybe the files of these extensions are missing there because of e.g. a permission issue? Additionally, consider not using the Connect Manager - it creates more problems than it solves. – Simon Sep 11 '14 at 10:56
  • Seemingly you are right! The troubled extensions are set at permission level 666, while the others are 777. I tried to change said extensions to 777 but it still didn't help!?? Any ideas? – pozitronic Sep 11 '14 at 11:13
  • As long as the XML files are present under var/package/, the Connect manager should show them anyway... – Simon Sep 11 '14 at 11:19
1

I had this problem also. Running a chown. Did not work for me.

What I had to do was, rename Cache.cfg and connect.cfg. Looks they had corrupted.Once I renamed next time I accessed Connect. Voila, new versions of the files were created. And I could see all my extensions again.

1

Cache.cfg and connect.cfg had nobody:nobody as the username:group in the downloader/ folder.

Logging into root account, and running chown username:group <file> on those two files to the proper username:group solved this problem.

0

Download the extension again and from the root copy package.xml into /var/package open the package.xml file.

Get the name then rename file file to match I,e in my case I had to rename package.xml to M2epro_ebay_magento-6.4.10.xml.

Then I logged out of Magento connect manager and logged back in. Now my extension shows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.