1

Magento 2.4.4 trying to composer update and getting below error

Magento 2.4.4 trying to update and getting below error

Can anyone please suggest some solution for the same.

3 Answers 3

1

Run below commands

composer require magento/product-community-edition 2.4.4 --no-update

composer update --ignore-platform-reqs

php bin/magento s:up

php bin/magento s:s:d -f

php bin/magento s:d:c

php bin/magento in:rein

php bin/magento c:c
5
  • thank you for your reply but when going to fire the command "composer update --ignore-platform-reqs" getting attached image error. ibb.co/kDnjwmt
    – Yogesh
    Commented Apr 30, 2022 at 9:55
  • @Yogesh please run all commands in a given sequence.
    – Msquare
    Commented Apr 30, 2022 at 9:56
  • tried same but on the second command its showing above error as attached on last comment
    – Yogesh
    Commented Apr 30, 2022 at 10:09
  • @Yogesh please check I got this : magento.stackexchange.com/questions/355385/…
    – Msquare
    Commented Apr 30, 2022 at 10:11
  • tried same as like mentioned in the link but no luck
    – Yogesh
    Commented Apr 30, 2022 at 10:24
0

I'm having a similar problem upgrading from 2.4.2 to 2.4.4

I follow the commands from both Adobe and Above

  1. composer require magento/product-community-edition 2.4.4 --no-update Response: /public$ composer update Loading composer repositories with package information

  2. composer update --ignore-platform-reqs Response:

    Loading composer repositories with package information Info from https://repo.packagist.org: #StandWithUkraine In Laminas\DependencyPlugin\DependencyRewriterV2::onPrePoolCreate Updating dependencies Your requirements could not be resolved to an installable set of packages.

Problem 1 - Root composer.json requires magento/product-community-edition 2.4.4 -> satisfiable by magento/product-community-edition[2.4.4]. - Conclusion: don't install ramsey/uuid 4.2.2 (conflict analysis result) - Conclusion: don't install ramsey/uuid 4.2.3 (conflict analysis result) - Conclusion: install magento/magento2-functional-testing-framework 3.3.0 (conflict analysis result) - allure-framework/allure-codeception[1.4.0, ..., 1.4.1] require codeception/codeception ^2.3|^3.0 -> satisfiable by codeception/codeception[2.3.0, ..., 2.5.6, 3.0.0, ..., 3.1.3]. - codeception/codeception[2.4.1, ..., 2.5.6] require codeception/phpunit-wrapper ^6.0.9|^7.0.6 -> satisfiable by codeception/phpunit-wrapper[6.0.9, ..., 6.8.4, 7.0.6, ..., 7.8.4]. - codeception/codeception 2.4.0 requires codeception/phpunit-wrapper ^6.0|^7.0 -> satisfiable by codeception/phpunit-wrapper[6.0.0, ..., 6.8.4, 7.0.0, ..., 7.8.4]. - codeception/codeception[3.0.0, ..., 3.1.3] require codeception/phpunit-wrapper >6.0.15 <6.1.0 | ^6.6.1 | ^7.7.1 | ^8.0.3 -> satisfiable by codeception/phpunit-wrapper[6.0.16, ..., 6.8.4, 7.7.1, ..., 7.8.4, 8.0.3, ..., 8.1.6]. - magento/product-community-edition 2.4.4 requires magento/framework 103.0.4 -> satisfiable by magento/framework[103.0.4]. - codeception/phpunit-wrapper[6.0.0, ..., 6.0.10] require phpunit/phpunit >=4.8.28 <5.0.0 || >=5.6.3 <7.0 -> found phpunit/phpunit[4.8.28, ..., 4.8.36, 5.6.3, ..., 5.7.27, 6.0.0, ..., 6.5.14] but it conflicts with your root composer.json require (^9). - codeception/codeception[2.3.7, ..., 2.3.9] require phpunit/phpunit >=4.8.28 <5.0.0 || >=5.6.3 <7.0 -> found phpunit/phpunit[4.8.28, ..., 4.8.36, 5.6.3, ..., 5.7.27, 6.0.0, ..., 6.5.14] but it conflicts with your root composer.json require (^9). - codeception/phpunit-wrapper[6.0.2, 7.0.0, ..., 7.0.6] require phpunit/phpunit ^7.0 -> found phpunit/phpunit[7.0.0, ..., 7.5.20] but it conflicts with your root composer.json require (^9). - codeception/phpunit-wrapper[6.0.11, ..., 6.0.12] require phpunit/phpunit >=5.7.27 <7.0 -> found phpunit/phpunit[5.7.27, 6.0.0, ..., 6.5.14] but it conflicts with your root composer.json require (^9). - codeception/phpunit-wrapper[6.0.13, ..., 6.1.3] require phpunit/phpunit >=5.7.27 <6.5.13 -> found phpunit/phpunit[5.7.27, 6.0.0, ..., 6.5.12] but it conflicts with your root composer.json require (^9). - codeception/phpunit-wrapper[6.0.15, 7.7.0, ..., 7.8.4] require phpunit/phpunit 7.5.* -> found phpunit/phpunit[7.5.0, ..., 7.5.20] but it conflicts with your root composer.json require (^9). - codeception/phpunit-wrapper[6.1.0, ..., 6.8.4] require phpunit/phpunit >=6.5.13 <7.0 -> found phpunit/phpunit[6.5.13, 6.5.14] but it conflicts with your root composer.json require (^9). - codeception/phpunit-wrapper[7.1.0, ..., 7.1.4] require phpunit/phpunit ^7.1 -> found phpunit/phpunit[7.1.0, ..., 7.5.20] but it conflicts with your root composer.json require (^9). - codeception/phpunit-wrapper 7.2.0 requires phpunit/phpunit ~7.1.0|~7.2.0 -> found phpunit/phpunit[7.1.0, ..., 7.2.7] but it conflicts with your root composer.json require (^9). - codeception/phpunit-wrapper[7.3.0, ..., 7.3.2] require phpunit/phpunit ~7.1.0|~7.2.0|~7.3.0 -> found phpunit/phpunit[7.1.0, ..., 7.3.5] but it conflicts with your root composer.json require (^9). - codeception/phpunit-wrapper 7.4.0 requires phpunit/phpunit >=7.1 <7.5 -> found phpunit/phpunit[7.1.0, ..., 7.4.5] but it conflicts with your root composer.json require (^9). - codeception/phpunit-wrapper[7.5.0, ..., 7.6.1] require phpunit/phpunit >=7.1 <7.6 -> found phpunit/phpunit[7.1.0, ..., 7.5.20] but it conflicts with your root composer.json require (^9). - codeception/phpunit-wrapper[8.0.3, ..., 8.1.6] require phpunit/phpunit ^8.0 -> found phpunit/phpunit[8.0.0, ..., 8.5.27] but it conflicts with your root composer.json require (^9). - codeception/codeception 2.3.0 requires phpunit/phpunit >4.8.20 <6.0 -> found phpunit/phpunit[4.8.21, ..., 4.8.36, 5.0.0, ..., 5.7.27] but it conflicts with your root composer.json require (^9). - codeception/codeception[2.3.1, ..., 2.3.6] require phpunit/phpunit >4.8.20 <7.0 -> found phpunit/phpunit[4.8.21, ..., 4.8.36, 5.0.0, ..., 5.7.27, 6.0.0, ..., 6.5.14] but it conflicts with your root composer.json require (^9). - Root composer.json requires magento/magento2-functional-testing-framework ^3.0 -> satisfiable by magento/magento2-functional-testing-framework[3.0.0, ..., 3.10.0]. - allure-framework/allure-phpunit[1.2.0, ..., 1.2.3] require allure-framework/allure-php-api ~1.1.0 -> satisfiable by allure-framework/allure-php-api[1.1.0, ..., 1.1.8]. - You can only install one version of a package, so only one of these can be installed: allure-framework/allure-php-api[1.1.0, ..., 1.4.0]. - Conclusion: don't install one of allure-framework/allure-php-api[1.2.1], allure-framework/allure-phpunit[1.2.4] (conflict analysis result) - allure-framework/allure-codeception 1.4.5 requires allure-framework/allure-php-api ~1.2.1 -> satisfiable by allure-framework/allure-php-api[1.2.1]. - magento/magento2-functional-testing-framework 3.3.0 requires allure-framework/allure-codeception ~1.4.0 -> satisfiable by allure-framework/allure-codeception[1.4.0, ..., 1.4.5]. - allure-framework/allure-codeception[1.4.3, ..., 1.4.4] require allure-framework/allure-php-api ~1.1.8 -> satisfiable by allure-framework/allure-php-api[1.1.8]. - allure-framework/allure-codeception 1.4.2 requires allure-framework/allure-php-api ~1.1.7 -> satisfiable by allure-framework/allure-php-api[1.1.7, 1.1.8]. - allure-framework/allure-php-api[1.1.6, ..., 1.1.8] require ramsey/uuid ^3.0 -> satisfiable by ramsey/uuid[3.0.0, ..., 3.9.6]. - allure-framework/allure-php-api 1.1.5 requires ramsey/uuid ^3.0.0 -> satisfiable by ramsey/uuid[3.0.0, ..., 3.9.6]. - Only one of these can be installed: rhumsaa/uuid[2.7.0, ..., 2.8.2], ramsey/uuid[3.0.0, ..., 3.9.6, 4.0.0, ..., 4.3.1]. ramsey/uuid replaces rhumsaa/uuid and thus cannot coexist with it. - magento/framework 103.0.4 requires ramsey/uuid ~4.2.0 -> satisfiable by ramsey/uuid[4.2.0, 4.2.1, 4.2.2, 4.2.3]. - Conclusion: don't install ramsey/uuid 4.2.1 (conflict analysis result) - Root composer.json requires allure-framework/allure-phpunit ~1.2.0 -> satisfiable by allure-framework/allure-phpunit[1.2.0, ..., 1.2.4].

Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions. storm02:~/public$ ^C

cheers, Joe

0

im getting this problem after the 2nd command, Any help please

composer update --ignore-platform-reqs Loading composer repositories with package information Updating dependencies Your requirements could not be resolved to an installable set of packages.

Problem 1 - Root composer.json requires magento/product-community-edition 2.4.4 -> satisfiable by magento/product-community-edition[2.4.4]. - magento/product-community-edition 2.4.4 requires colinmollenhour/cache-backend-redis 1.14.2 -> found colinmollenhour/cache-backend-redis[1.14.2] but it conflicts with your root composer.json require (1.11.0). Problem 2 - composer/composer[1.9.0, ..., 1.9.3] require symfony/finder ^2.7 || ^3.0 || ^4.0 -> found symfony/finder[v2.7.0, ..., v2.8.52, v3.0.0, ..., v3.4.47, v4.0.0, ..., v4.4.44] but it conflicts with your root composer.json require (^5.2). - Root composer.json requires magento/composer 1.6.0 -> satisfiable by magento/composer[1.6.0]. - magento/composer 1.6.0 requires composer/composer ^1.9 -> satisfiable by composer/composer[1.9.0, ..., 1.10.26]. - composer/composer[1.10.0, ..., 1.10.26] require composer/semver ^1.0 -> satisfiable by composer/semver[1.0.0, ..., 1.7.2]. - You can only install one version of a package, so only one of these can be installed: composer/semver[1.0.0, ..., 1.7.2, 2.0.0, 3.0.0, ..., 3.3.2]. - friendsofphp/php-cs-fixer v3.4.0 requires composer/semver ^3.2 -> satisfiable by composer/semver[3.2.0, ..., 3.3.2]. - Root composer.json requires friendsofphp/php-cs-fixer ~3.4.0 -> satisfiable by friendsofphp/php-cs-fixer[v3.4.0].

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.