2

I am getting below issue while upgrading to Magento version 2.4.4 on php 8

Your requirements could not be resolved to an installable set of packages.

Problem 1 - phpunit/phpunit 6.5.14 requires php ^7.0 -> your PHP version (8.1.4) does not satisfy that requirement. - phpunit/phpunit 6.5.9 requires php ^7.0 -> your PHP version (8.1.4) does not satisfy that requirement. - phpunit/phpunit 6.5.8 requires php ^7.0 -> your PHP version (8.1.4) does not satisfy that requirement. - phpunit/phpunit 6.5.7 requires php ^7.0 -> your PHP version (8.1.4) does not satisfy that requirement. - phpunit/phpunit 6.5.6 requires php ^7.0 -> your PHP version (8.1.4) does not satisfy that requirement. - phpunit/phpunit 6.5.5 requires php ^7.0 -> your PHP version (8.1.4) does not satisfy that requirement. - phpunit/phpunit 6.5.4 requires php ^7.0 -> your PHP version (8.1.4) does not satisfy that requirement. - phpunit/phpunit 6.5.3 requires php ^7.0 -> your PHP version (8.1.4) does not satisfy that requirement. - phpunit/phpunit 6.5.2 requires php ^7.0 -> your PHP version (8.1.4) does not satisfy that requirement. - phpunit/phpunit 6.5.14 requires php ^7.0 -> your PHP version (8.1.4) does not satisfy that requirement. - phpunit/phpunit 6.5.13 requires php ^7.0 -> your PHP version (8.1.4) does not satisfy that requirement. - phpunit/phpunit 6.5.12 requires php ^7.0 -> your PHP version (8.1.4) does not satisfy that requirement. - phpunit/phpunit 6.5.11 requires php ^7.0 -> your PHP version (8.1.4) does not satisfy that requirement. - phpunit/phpunit 6.5.10 requires php ^7.0 -> your PHP version (8.1.4) does not satisfy that requirement. - phpunit/phpunit 6.5.1 requires php ^7.0 -> your PHP version (8.1.4) does not satisfy that requirement. - phpunit/phpunit 6.5.0 requires php ^7.0 -> your PHP version (8.1.4) does not satisfy that requirement. - Installation request for phpunit/phpunit ~6.5.0 -> satisfiable by phpunit/phpunit[6.5.0, 6.5.1, 6.5.10, 6.5.11, 6.5.12, 6.5.13, 6.5.14, 6.5.2, 6.5.3, 6.5.4, 6.5.5, 6.5.6, 6.5.7, 6.5.8, 6.5.9].

Do we need to upgrade the phpunit version manually?

3 Answers 3

5

you need to find the "require-dev" in your magento root composer.json file

"require-dev": {
        "allure-framework/allure-phpunit": "~1.5.0",
        "dealerdirect/phpcodesniffer-composer-installer": "^0.7.0",
        "friendsofphp/php-cs-fixer": "~3.3.0",
        "lusitanian/oauth": "~0.8.10",
        "magento/magento-coding-standard": "*",
        "magento/magento2-functional-testing-framework": "^3.7",
        "pdepend/pdepend": "~2.10.0",
        "phpmd/phpmd": "^2.9.1",
        "phpstan/phpstan": "~1.2.0",
        "phpunit/phpunit": "~9.5.0",
        "sebastian/phpcpd": "^6.0.3",
        "squizlabs/php_codesniffer": "~3.6.0",
        "symfony/finder": "^5.2"
    }

replace this code after you need just run composer update command

0

Looks like your outdated list of PHPUnit versions. I believe only PHPUnit 9+ has PHP 8 compatibility Try to clean up the composer cache by executing composer clearcache

0

You need to manually update the version of phpunit/phpunit 6.5.14 to "phpunit/phpunit": "^9" in composer.json After then run below command:

composer require magento/product-community-edition 2.4.4 --no-update

composer update

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.