0

I have a problem when installing a module with composer, no matter which module, I get the same error. (In PluginManager.php(273) : eval()'d code line 188)

Magento v2.4, PHP 8.1

run

 composer require sendinblue/module-sendinblue

Result:

Using version ^2.1 for sendinblue/module-sendinblue
./composer.json has been updated
Running composer update sendinblue/module-sendinblue
Loading composer repositories with package information
In Laminas\DependencyPlugin\DependencyRewriterV2::onPrePoolCreate
Updating dependencies
Lock file operations: 1 install, 0 updates, 0 removals
  - Locking sendinblue/module-sendinblue (2.1.11)
Writing lock file
Installing dependencies from lock file (including require-dev)
Package operations: 1 install, 0 updates, 0 removals
  - Downloading sendinblue/module-sendinblue (2.1.11)
Info from https://repo.packagist.org: #StandWithUkraine
  - Installing sendinblue/module-sendinblue (2.1.11): Extracting archive
Generating autoload files
121 packages you are using are looking for funding.
Use the `composer fund` command to find out more!

In PluginManager.php(273) : eval()'d code line 188:
                                    
  chmod(): Operation not permitted  
                                    

Do you have any idea what the problem is? Thanks very much

1

1 Answer 1

1

Just reset permission or try using : sudo su.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.