0

We had so many serious problems with Magento 2.4.2-p1 and Magento 2.4.3-p1. I am hoping that today released version Magento 2.4.4 will work better for us (to be fair - the issues we had might have stemmed from us using the Magento Migration Tool).

I was hoping I could just simply install Magento 2.4.4 via Softaculous (WHM/Cpanel) but it is not available there yet. I have reached out to my hosting company and they offered to install this for me. I know there are 2 basic versions available:

- WITH Sample Data
- WITHOUT Sample Data

Which is recommended? I will be exporting products in a CSV format from Magento 2.4.3-p1 and importing into Magento 2.4.4. - same with products and customers.

Are there any other things I should mention to my hosting company when asking them to do the install for me?

3 Answers 3

1

Install with sample data when you develop a general module and want to test it, and without sample data if you want to have a "real" shop.

1

Both approach with and without sample data has it's own pros and cons. I am not sure at what stage you are at with your 2.4.x installation still putting my 2 cents below.

If you go with sample data you'll have a website up and running with nice look and feel. You'll have Home page, PDP page etc designed and look nice. If you go without sample data you'll have to design everything from the scratch.

Obviously you are not going to use sample data, you'll have to clean that up means delete or remove test data, redesign some blocks, pages, replace images etc. If you go without sample data you do not need any cleanup as you are going to build everything from the scratch.

2
  • So if I want to Import products, customers and orders via CSV import, then install the Smartwave Porto theme and extensions from Amasty, it would be better to go WITHOUT sample data, correct?
    – Allysin
    Apr 12 at 22:11
  • Yes that is correct.
    – Taran
    Apr 22 at 19:49
0

If you want to import

  • Products
  • Categories
  • Orders
  • Customers
  • Other data, etc

from your already existing site in new installation of Magento 2.4.4, Then, I suggest to go for magento 2.4.4 installation without sample data.

Also Ask your hosting company to have PHP8.x

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.