2

I'm installing PWA Studio on my local and i'm using magento 2.3.3 without sample data but i'm getting error as shown in image below. I have followed all the steps for pwa setup but while running this command yarn run build and yarn run watch It's showing error

venia-sample-backends is a "development-only" extension, please remove it from your project's package.json before going to production.

Error: Environment has 1 validation errors: 
 (1) https://www.pwa-magento.com/ is inactive. Please consider using one of these other backends: 

 [{"name":"2.4.1-cloud-meta-package","description":"Magento 2.4.1 with Venia sample data installed","url":"https://master-7rqtwti-mfwmkrjfqvbjk.us-4.magentosite.cloud/"},{"name":"2.4-develop","description":"Magento 2.4-develop with Venia sample data installed","url":"https://venia-develop-ccewfjy-mfwmkrjfqvbjk.us-4.magentosite.cloud/"}]

Screenshot

I'm using yarn and node versions yarn version:- 1.22.18 and node version:- v14.19.1

Let me know if anyone has any solution.

2
  • did you find any solution for this
    – Rana Zain
    Commented Feb 8, 2023 at 14:35
  • @RanaZain no i guess i don't remember but I might have tried installing again different way
    – Mohit Rane
    Commented Feb 14, 2023 at 14:14

1 Answer 1

2

Remove venia-sample-backends package

yarn remove @magento/venia-sample-backends
yarn upgrade

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.