0

I want to install league/flysystem-cached-adapter 1.1 but it throws the following error on composer require

Problem 1
    - Root composer.json requires magento/product-enterprise-edition 2.4.3-p1 -> satisfiable by magento/product-enterprise-edition[2.4.3-p1].
    - Conclusion: don't install league/flysystem 2.0.2 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.0.3 (conflict analysis result)
    - Conclusion: don't install league/flysystem 1.1.5 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.0.4 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.0.5 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.0.6 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.0.7 (conflict analysis result)
    - Conclusion: don't install league/flysystem 1.1.6 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.0.8 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.1.0 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.1.1 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.2.0 (conflict analysis result)
    - Conclusion: don't install league/flysystem 1.1.7 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.2.1 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.2.2 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.2.3 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.3.0 (conflict analysis result)
    - Conclusion: don't install league/flysystem 1.1.8 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.3.1 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.3.2 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.4.0 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.4.1 (conflict analysis result)
    - Conclusion: don't install league/flysystem 1.1.9 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.4.2 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.4.3 (conflict analysis result)
    - magento/product-community-edition 2.4.3-p1 requires magento/module-aws-s3 100.4.1-p1 -> satisfiable by magento/module-aws-s3[100.4.1-p1].
    - magento/product-enterprise-edition 2.4.3-p1 requires magento/product-community-edition 2.4.3-p1 -> satisfiable by magento/product-community-edition[2.4.3-p1].
    - Root composer.json requires league/flysystem-cached-adapter ^1.1 -> satisfiable by league/flysystem-cached-adapter[1.1.0].
    - league/flysystem-cached-adapter 1.1.0 requires league/flysystem ~1.0 -> satisfiable by league/flysystem[1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.0.8, 1.0.9, 1.0.10, 1.0.11, 1.0.12, 1.0.13, 1.0.14, 1.0.15, 1.0.16, 1.0.17, 1.0.18, 1.0.19, 1.0.20, 1.0.21, 1.0.22, 1.0.23, 1.0.24, 1.0.25, 1.0.26, 1.0.27, 1.0.28, 1.0.29, 1.0.30, 1.0.31, 1.0.32, 1.0.33, 1.0.34, 1.0.35, 1.0.36, 1.0.37, 1.0.38, 1.0.39, 1.0.40, 1.0.41, 1.0.42, 1.0.43, 1.0.44, 1.0.45, 1.0.46, 1.0.47, 1.0.48, 1.0.49, 1.0.50, 1.0.51, 1.0.52, 1.0.53, 1.0.54, 1.0.55, 1.0.56, 1.0.57, 1.0.58, 1.0.59, 1.0.60, 1.0.61, 1.0.62, 1.0.63, 1.0.64, 1.0.65, 1.0.66, 1.0.67, 1.0.68, 1.0.69, 1.0.70, 1.1.0, 1.1.1, 1.1.2, 1.1.3, 1.1.4, 1.1.5, 1.1.6, 1.1.7, 1.1.8, 1.1.9].
    - You can only install one version of a package, so only one of these can be installed: league/flysystem[1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.0.8, 1.0.9, 1.0.10, 1.0.11, 1.0.12, 1.0.13, 1.0.14, 1.0.15, 1.0.16, 1.0.17, 1.0.18, 1.0.19, 1.0.20, 1.0.21, 1.0.22, 1.0.23, 1.0.24, 1.0.25, 1.0.26, 1.0.27, 1.0.28, 1.0.29, 1.0.30, 1.0.31, 1.0.32, 1.0.33, 1.0.34, 1.0.35, 1.0.36, 1.0.37, 1.0.38, 1.0.39, 1.0.40, 1.0.41, 1.0.42, 1.0.43, 1.0.44, 1.0.45, 1.0.46, 1.0.47, 1.0.48, 1.0.49, 1.0.50, 1.0.51, 1.0.52, 1.0.53, 1.0.54, 1.0.55, 1.0.56, 1.0.57, 1.0.58, 1.0.59, 1.0.60, 1.0.61, 1.0.62, 1.0.63, 1.0.64, 1.0.65, 1.0.66, 1.0.67, 1.0.68, 1.0.69, 1.0.70, 1.1.0, 1.1.1, 1.1.2, 1.1.3, 1.1.4, 1.1.5, 1.1.6, 1.1.7, 1.1.8, 1.1.9, 2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.7, 2.0.8, 2.1.0, 2.1.1, 2.2.0, 2.2.1, 2.2.2, 2.2.3, 2.3.0, 2.3.1, 2.3.2, 2.4.0, 2.4.1, 2.4.2, 2.4.3].
    - magento/module-aws-s3 100.4.1-p1 requires league/flysystem ^2.0 -> satisfiable by league/flysystem[2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.7, 2.0.8, 2.1.0, 2.1.1, 2.2.0, 2.2.1, 2.2.2, 2.2.3, 2.3.0, 2.3.1, 2.3.2, 2.4.0, 2.4.1, 2.4.2, 2.4.3].
    - Conclusion: don't install league/flysystem 2.0.1 (conflict analysis result)

The main conflict is as follows:

magento/module-aws-s3 100.4.1-p1 requires league/flysystem ^2.0

but

league/flysystem-cached-adapter 1.1.0 requires league/flysystem ~1.0

How to resolve this dependency?

As far as I checked on packagist the latest version of league/flysystem-cached-adapter is 1.1

https://packagist.org/packages/league/flysystem-cached-adapter

2 Answers 2

0

Use this command to ignore the platform requests

composer require vendor/module-name --ignore-platform-req

A new feature in Composer v2 allows you to selectively ignore platform requirements.

0

Run below command from terminal

composer require league/flysystem 2.x-dev --no-update

and then try to run

composer update

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.