1

Here is the correct error code, Version 1.9.1:

Cannot send headers; headers already sent in /home/customer/www/abc/public_html/app/code/core/Mage/Core/functions.php, line 32

Trace:
#0 /home/customer/www/abc/public_html/lib/Zend/Controller/Response/Abstract.php(115): Zend_Controller_Response_Abstract->canSendHeaders(true)
#1 /home/customer/www/abc/public_html/app/code/core/Mage/Core/Model/App.php(1246): Zend_Controller_Response_Abstract->setHeader('Content-Type', 'text/html; char...')
#2 /home/customer/www/abc/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(80): Mage_Core_Model_App->getResponse()
#3 /home/customer/www/abc/public_html/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(202): Mage_Core_Controller_Varien_Front->getResponse()
#4 /home/customer/www/abc/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(172): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#5 /home/customer/www/abc/public_html/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
#6 /home/customer/www/abc/public_html/app/Mage.php(683): Mage_Core_Model_App->run(Array)
#7 /home/customer/www/abc/public_html/index.php(103): Mage::run('base', 'website')
#8 {main}

What is frustrating is nothing has happened to this site for months, nobody has touched it. But looking through the logs something tried to happen early hours of this morning:

2022-04-05 09:28:22 UTC [nginx][error] 79543#0: *33157383 openat() "/home/u558-baj60g34iomx/www/abc.com/public_html/.well-known/autoconfig/mail/autodiscover.xml" failed (2: No such file or directory), client: 81.130.224.19, server: abc.com, request: "POST /autodiscover/autodiscover.xml HTTP/1.1", host: "abc.com"

2022-04-05 02:04:23 UTC [apache][:notice] [pid 93365] [client 194.26.29.143:60440] mod_hive matched URI http://abc.co.uk/downloader/index.php (/home/u558-baj60g34iomx/www/abc.com/public_html/downloader/index.php) with match 12

So as I understand it, and not being any type of expert on Magento, this error is normally to do with a space. But without knowing what has been updated, or where to look to find any space I am a little lost.

Could anyone please point me in the right direction? This site needs to be fixed as soon as.

Many Thanks

Addy

5
  • have you checked your php version changed or same as before?? Apr 5 at 12:10
  • Hello, thank you for the idea. I am not sure what it was before, but I have returned it to 7.3.33. It is an old Magneto so I am not sure what version of PHP Magneto 1.9.1 should be on. Could this be the issue ?
    – BadAddy
    Apr 5 at 12:16
  • I am not sure if this is any help, but on Chrome I get an 503 error on loading the reports.php?
    – BadAddy
    Apr 5 at 12:21
  • Php version can possible reason. Apr 5 at 12:23
  • Hello @GohilRajesh. You are correct, our provider did a mass update of PHP and remove, completely, the old version the site worked on. Thank you for your help.
    – BadAddy
    Apr 5 at 12:57

1 Answer 1

0

I couldn't respond in the comments because I don't have any reputation here but I was wondering if you ever solved this problem?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.