1

I'm using a centos 7 server where I've installed nginx, php, mysql, elsaticsearch and ceated a magento setup.

In the magento admin > stores > Configuration > catalog > Catalog > Catalog Search I'm getting No alive nodes found in your cluster

Although the indexing is running properly and I can see it in Elasticsearch log.

Please let me know what I'm doing wrong over here.

Please have a look at the below given admin configuration.

admin configuration

When I'm calling from terminal this is what I'm getting

enter image description here

Below is the indexer result.

enter image description here

2
  • replace localhost in hostname with 127.0.0.1:9200 then try.
    – Mehran
    Apr 1, 2022 at 9:23
  • @Mehran tried it but the result is same. Apr 1, 2022 at 9:33

5 Answers 5

2

Did anyone have success fixing this error?

I have the same error, indexing via cli is working but the Storefront and Admin have the error "No alive nodes found in your cluster"

Update:

I resolved my error - issue was CentOS SELinux and permissions set to Enforcing.

Changing SELinux permissions to Permissive resolved the issue for me.

setenforce 0

Note: I faced the same issue where Indexing worked correct via command line, but not on front/back end admin. This has fixed my issue.. good luck.

0
0

Check the configuration First let's check if your configuration is correct:

Update your host and port: '[host]:[port]'. E.g.: localhost:9200 in Stores > Settings > Configuration > Catalog > Catalog > Catalog Search or if you are you are using Elastic Suite in Stores > Configuration > ElasticSuit > Basic configuration as per your setting.

Update your indices alias name and indices name pattern in admin configuration same as above.

Clear cache by going to System > Cache Management or using this command (on your server in Magento installation folder):

php bin/magento cache:clean

Reindex by visiting System > Index Management or running command below:

Update catalog search

php bin/magento indexer:reindex catalogsearch_fulltext 

Or reindex all indexers

php bin/magento indexer:reindex

Check Elasticsearch If the error still stands, it might be the issue with the elasticsearch service on your server. To solve this follow the steps below:

Log into your Magento instance.

Check if the elasticsearch is running:

sudo /etc/init.d/elasticsearch status

Try to start it if it's not running, or restart it if it's running:

Start elasticsearch

sudo systemctl start elasticsearch

Or restart elasticsearch

sudo systemctl restart elasticsearch

You've found the issue if you encounter an error here and your elasticsearch doesn't start. Solve the issue first. Continue when the elasticsearch starts.

Navigate to your Magento installation folder

Reindex all indexers

php bin/magento indexer:reindex

Clear the cache

php bin/magento cache:flush

Your problem should have been solved by now.

1
  • I did all the above steps, status is still same , as mentioned in the question, indexing is working but issue is coming on Magento admin and storefront. Apr 1, 2022 at 12:41
0

If you are using Magento and getting 'No alive nodes found in your cluster' error while reindexing.

Make sure you have updated following :

Your Host and port : '[host]:[port]'. Eg: 'es-node1.fqdn:9200, es-node2.fqdn:9200' or 'localhost:9200' in Admin -> Store -> Configuration -> Catalog -> Catalog -> Catalog Search. Update your indices alias name and indices name pattern in admin configuration same as above. Try this, and clear cache and reindex. It will solve your issue.

If you are using Magento and getting 'No alive nodes found in your cluster' error while reindexing.

Make sure you have updated following :

Your Host and port : '[host]:[port]'. Eg: 'es-node1.fqdn:9200, es-node2.fqdn:9200' or 'localhost:9200' in Admin -> Store -> Configuration -> Catalog -> Catalog -> Catalog Search. Update your indices alias name and indices name pattern in admin configuration same as above. Try this, and clear cache and reindex. It will solve your issue.

enter image description here

0

Please check if you are closing the Elasticsearch cmd panel. Don't close that window. So that Elasticsearch will be on otherwise it will disable.

After that run these commands:

php bin/magento setup:upgrade
php bin/magento setup:di:compile
0

I have experienced the similar issue and i have found that Opensearch was working but still it keep displaying "No alive nodes found in your cluster" After spending hours i was able to figure out that security issue Our local website was on http and running the cmd curl http://localhost:9200 returned curl: (52) Empty reply from server

On the other side curl https://localhost:9200 is returning the required result

Solution You need to configure the SSL locally to resolve this issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.