1

I am trying to access frontend of magento 2.4.3 But getting

Use of undefined constant SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES - assumed 'SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES' (this will throw an Error in a future version of PHP) in /Applications/XAMPP/xamppfiles/htdocs/magento2/lib/internal/Magento/Framework/Encryption/Adapter/SodiumChachaIetf.php on line 40

error.

I have enabled sodium php extension too.

Any thoughts on fixing this issue?

2
  • 1
    can you check the sodium php extension is installed
    – KAndy
    Commented Mar 26, 2022 at 4:17
  • I have the same problem, but I don't have access to SSH I have shared hosting Cpanel How can I solve this problem?
    – Johny
    Commented Nov 13, 2022 at 14:17

1 Answer 1

2

For me works

  1. Add "extension=sodium" to php.ini (no quotes)
  2. Copy php/libsodium.dll to apache/bin/
  3. Restart Server

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.