0

I manage a multisite system for work, with Magento 2.3.3 Community Edition My hosting is managed, and they recently rolled out Composer 2 for all customers on their hosting.

I'm trying to update the site, plugins etc however I'm encountering lots of problems which seem to stem from Composer 2 as I consistently get the error

You are using Composer 2, which some of your plugins seem to be incompatible with. Make sure you update your plugins or report a plugin-issue to ask them to support Composer 2

I'm unable to roll back to composer 1, and trying to update dependencies has me going round in a loop of unsatisfiable plugins

Problem 1
- magento/composer-root-update-plugin is locked to version 1.0.0 and an update of this package was not requested.
- magento/composer-root-update-plugin 1.0.0 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint.
Problem 2
- magento/product-community-edition is locked to version 2.3.3 and an update of this package was not requested.
- magento/product-community-edition 2.3.3 requires php ~7.1.3||~7.2.0||~7.3.0 -> your php version (7.4.28) does not satisfy that requirement.
Problem 3
- Root composer.json requires dealerdirect/phpcodesniffer-composer-installer ^0.5.0 -> satisfiable by dealerdirect/phpcodesniffer-composer-installer[v0.5.0].
- dealerdirect/phpcodesniffer-composer-installer v0.5.0 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint.
Problem 4
- magento/framework 102.0.3 requires php ~7.1.3||~7.2.0||~7.3.0 -> your php version (7.4.28) does not satisfy that requirement.
- yireo/magento2-webp2 0.8.0 requires magento/framework ^101.0.1|^101.1|^102.0|^103.0 -> satisfiable by magento/framework[102.0.3].
- yireo/magento2-webp2 is locked to version 0.8.0 and an update of this package was not requested.

I've tried updating each plugin individually but always seem to get routed back to the same few core componenets that also don't update.

I realise this isn't a programming issue, but would appreciate any help or sensible suggestions on how to proceed

1 Answer 1

1

The error is related to composer you can downgrade the composer using these steps:

  1. Run this command on your magento root wget https://getcomposer.org/download/1.10.17/composer.phar

2.then run the commands with composer.phar instead of direct composer : php -dmemory_limit=4G composer.phar clearcache
php -dmemory_limit=4G composer.phar update

and also you need to downgrade your php to 7.3

3
  • I think my host controls the Composer version ~ at the moment no upgrade / downgrade commands are successful through the CLI but I appreciate the idea Mar 1, 2022 at 12:03
  • That's why I suggested wget , it will work like portable composer instead of installation Mar 2, 2022 at 4:17
  • Downgrading composer seems to be the way forward, I've asked my host to perform this for me and I'm working on the updates now. Thankyou Mar 2, 2022 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.