0

I'm trying to upgrade magento 2.4.2 to 2.4.3-p1 with composer 2, but I'm stuck with is error:

Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Root composer.json requires allure-framework/allure-phpunit ~1.2.0 -> satisfiable by allure-framework/allure-phpunit[1.2.0, ..., 1.2.4].
    - magento/product-community-edition 2.4.3-p1 requires magento/framework 103.0.3-p1 -> satisfiable by magento/framework[103.0.3-p1].
    - Root composer.json requires magento/product-community-edition 2.4.3-p1 -> satisfiable by magento/product-community-edition[2.4.3-p1].
    - Root composer.json requires magento/magento2-functional-testing-framework ^3.0 -> satisfiable by magento/magento2-functional-testing-framework[3.0.0, ..., 3.8.0].
    - magento/framework[103.0.3, ..., 103.0.3-p1] require symfony/console ~4.4.0 -> satisfiable by symfony/console[v4.4.0, ..., v4.4.37].
    - You can only install one version of a package, so only one of these can be installed: symfony/console[2.0.4, ..., v2.8.52, v3.0.0, ..., v3.4.47, v4.0.0, ..., v4.4.37, v5.0.0, ..., v5.4.3, v6.0.0, v6.0.1, v6.0.2, v6.0.3].
    - Conclusion: install symfony/console v2.8.38 (conflict analysis result)

Any help on this? Thanks

1 Answer 1

0

You can try :

php bin/magento deploy:mode:set developer //set developer mode

php bin/magento -d memory_limit=6G maintenance:enable

composer require magento/product-community-edition 2.4.3 --no-update

composer update or upload composer.phar in root and run php -d memory_limit=6G composer.phar update

rm -rf var/cache/* generated/code/* var/view_preprocessed/* var/page_cache/* var/report/* pub/static/frontend/* pub/static/adminhtml/* pub/static/_cache/merged/*

php bin/magento setup:upgrade

php bin/magento setup:static-content:deploy -f

php bin/magento setup:di:compile

php bin/magento indexer:reindex

php bin/magento cache:clean

php bin/magento cache:flush

After upgrade, check your Magento version with the following command:

php bin/magento --version

php bin/magento maintenance:disable

Php version set 7.4 via cpanel or htaccess

Hope It will help !!

2
  • Sorry I forgot about this post, I found a solution and it was so simple that it makes feel dumb! I just tried to migrate version by version (24.2 ->2.4.2-p1 -> p2 and then 2.4.3.
    – crowd42
    Feb 27, 2022 at 12:39
  • ok Great 👍 !!!! Feb 28, 2022 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.