We have 67 products where we have just uploaded but the "Product Brand" has not been selected.

I have tried the following: A singular coloumn with title "product_brand": Rudy Project (in cells). Additional attributes with cells showing "product_brand=rudy project"

Both have not worked.

Any ideas?



  • Did you provide correct product brand name? for example; your csv is a in first column define manufacturer column in ad values of product brand i.e hp, dell. hope this will work. Jan 25, 2022 at 14:46

1 Answer 1


It's quite hard to assume the data structure for product CSV imports into Magento. I'd advise that you do the following:

  • Find a product with "Brand" data already defined correctly via admin panel (or manually set data for this attribute to a product)
  • Run a product export, filtered by this single SKU
  • See what the CSV data looks like from the export
  • Match the export data structure for "Brand" attribute in your import CSV

This approach usually works for me. Hope it helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.