When I run the Magento 2 command

php bin/magento setup:upgrade

I get the error below...

"Autoload error: Vendor autoload is not found. Please run 'composer install' under application root directory."

I have tried to re-install Composer successfully several times, so I think composer is not the issue.

Any suggestions?



2 Answers 2


This problem occurred because of your vendor folder is empty or not found all Magento core module. So you need to copy and paste vendor folder or run following command to generate all the code modules.

Go to root directory and run command

composer install

If composer install not works for you then run command

composer update --ignore-platform-reqs

I hope it will help you. Thank you.

Vendor autoload is not found. Please run 'composer install' under application root directory.

Run Below Commands

php -d memory_limit=-1 composer.phar install

php bin/magento setup:config:set
Overwrite the existing configuration for db-ssl-verify?[Y/n]Y
Overwrite the existing configuration for allow-parallel-generation?[Y/n]Y

Can't run this operation: deployment configuration is absent. Run 'magento setup:config:set --help' for options.

php bin/magento module:enable --all

php bin/magento module:disable Magento_TwoFactorAuth

php bin/magento config:set catalog/search/engine elasticsearch7
php bin/magento config:set catalog/search/elasticsearch7_server_hostname localhost
php bin/magento config:set catalog/search/elasticsearch7_server_port 9200
php bin/magento config:set catalog/search/elasticsearch7_index_prefix achadirect

Composer.phar installation

php -r "copy('https://getcomposer.org/installer', 'composer-setup.php');"

php -r "if (hash_file('SHA384', 'composer-setup.php') === '544e09ee996cdf60ece3804abc52599c22b1f40f4323403c44d44fdfdd586475ca9813a858088ffbc1f233e9b180f061') { echo 'Installer verified'; } else { echo 'Installer corrupt'; unlink('composer-setup.php'); } echo PHP_EOL;"

php composer-setup.php

php -r "unlink('composer-setup.php');"

php -dmemory_limit=-1 composer.phar

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.