1

i am working on magento store on local wampserver 2.4 .Ip address of my system is 192.168.15.32.these are my wamp settings

#Listen 12.34.56.78:80
Listen 80
<Directory />
    AllowOverride none
    Require all granted
</Directory>

E:\wamp\alias\phpmyadmin.confg

Alias /phpmyadmin "E:/wamp/apps/phpmyadmin4.0.4/" 

# to give access to phpmyadmin from outside 
# replace the lines
#
#      Order Deny,Allow
#   Deny from all
#   Allow from 127.0.0.1
#
# by
#
#        Order Allow,Deny 
#   Allow from all
#

<Directory "E:/wamp/apps/phpmyadmin4.0.4/">
    Options Indexes FollowSymLinks ExecCGI
    AllowOverride all
    Order Deny,Allow
    Deny from all
    Allow from 127.0.0.1
    Allow from ::1
    Allow from localhost
</Directory>

and my wamp is online color is green when i put 192.168.15.32 on another pc within lan the wamp page is open and when i click on my magento setup folder it show the error"unable to connect" or "not found" or "forbidden" however other folders on my wamp/www are accessible even phpmyadmin also working please help me to resolve this issue to access the magento in lan on different systems at same time

  • So you are trying to access your machine from another machine on your network? – brentwpeterson Sep 8 '14 at 15:29
  • yes i want to access my machine from another machine in LAN – kashif khan Sep 8 '14 at 15:42
  • What happens when you try to access a phoinfo() page? Can you access a test.html page to see if you even have a folder that is readable? – brentwpeterson Sep 8 '14 at 16:25
  • there are some other old projects in my wamp/www and they working except magento and when i put this address in my browser 192.168.15.32 it also works but not accessible from another pc – kashif khan Sep 8 '14 at 18:00
  • My Question is this: When you put an index.html file with some content like <h1>hello world</h1> does it resolve? Like this 192.168.15.32/index.html – brentwpeterson Sep 8 '14 at 18:14
1

Since magento require a domain name update your hosts file on your local machine

Hint: open the Windows HOSTS file (C:\\Windows\System32\drivers\etc\hosts) and add: 
192.168.15.32 www.localhost.com
192.168.15.32 localhost.com

Try not to use localhost you may run into other issues later on

Make sure your WampServer meet magento minimum system requirement and double check your folder setting

Take a look at Install Magento on WampServer few tricks and Installing on Windows with XAMPP and WAMP

  • i edited my windows hosts file now home page is open but images and css not load.and when i click on any navigation link it again show just localhost/projectfolder and page browser gives error unable to connect – kashif khan Sep 9 '14 at 11:11
  • resolved after doing above just go to admin panel>configuration>General>web> and in unsecure and secure url put the new url like in my case i put 192.168.15.32 – kashif khan Sep 9 '14 at 12:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.